JavaScript doesn't work with Google Map (marks)

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: saibamenppl, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

In ReactOS People Map (http://www.reactos.org/peoplemap/) if i select User, Translator or Language Maintainer - marks doesn't work. For Newsletter Author, Developer and Moderator it works.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.reactos.org/peoplemap/
2. Select User, Translator, Language Maintainer
Actual Results:  
Marks doesn't work.


This happend only on Firefox and IE.

Comment 1

7 years ago
Confirmed unable to filter users by selecting User, Translator, Language Maintainer

Able to reproduce in Firefox 3.6.16, 4.0
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

7 years ago
Response xml source contains invalid UTF-8 character of U+FFFF. 
I think this is TE.

Error in error console:

*Checked "Language Maintainer"

Error: not well-formed
Source file: http://www.reactos.org/peoplemap/ajax-getuser.php?query=3&subject=group&
Line: 1, Column: 538
Source code:
...
<fullname>Vytis Girdï¿¿ijauskas</fullname>

*Checked "Translator"

Error: not well-formed
Source file: http://www.reactos.org/peoplemap/ajax-getuser.php?query=9&subject=group&
Line: 1, Column: 967
Source code:
...
<fullname>Vytis Girdï¿¿ijauskas</fullname>

*Checked "User"
Error: not well-formed
Source file: http://www.reactos.org/peoplemap/ajax-getuser.php?query=10&subject=group&
Line: 1, Column: 7012
Source code:
...
<fullname>Tomi Mï¿¿kinen</
alice0775: you might want to put that up as an attachment if people actually need to see it.  I had to remove the characters you're complaining about in order for Bugzilla to display it.

Comment 4

7 years ago
Created attachment 527103 [details]
Responced xml when checked "User"

Invalid UTF-8 is includes in response xml.
Encoding error is treated as fatal XML errors.
This was introduced by Bug 174351.
Version: unspecified → 2.0 Branch

Updated

7 years ago
Blocks: 174351
Indeed, this looks like tech evangelism.  WebKit uses an XML parser that will output a partial DOM even if it hits a fatal error (and it might not even treat encoding errors as fatal).
Assignee: general → english-us
Component: JavaScript Engine → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: 2.0 Branch → unspecified
I've emailed the website coordinator as listed at http://www.reactos.org/en/contact.html
(Reporter)

Comment 7

7 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 8

7 years ago
As far as I can tell by looking at the URLs in comment 2, they "fixed" this by just deleting the characters...

Instead of sending an HTTP charset, or adding an XML processing instruction, or actually using UTF-8 (which would be the best solution), the 3 names in comment 2 have just been sanitized and had their nasty non-ASCII characters removed.

Vytis Girdijauskas should probably be Vytis Girdžijauskas and Tomi Mkinen should probably be Tomi Mäkinen.

Updated

7 years ago
Attachment #527103 - Attachment mime type: text/plain → text/plain; charset=utf-8

Comment 10

7 years ago
OK, I missed the part where the characters were U+FFFF. The change you made will stop encoding errors on the output by outputting numeric entities for characters above U+FF. In this case, it doesn't output anything though (which also avoids the encoding error) because U+FFFF isn't a valid character. Somewhere you have another problem where UTF-8 isn't being handled correctly and you're storing U+FFFF in the database instead of the actual characters. Once you fix that problem and replace/remove the invalid characters in the database, you won't need the change you made and can just output the characters raw (as the XML file is assumed to be UTF-8).
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.