Last Comment Bug 651089 - Make content/events/test/test_bug534833.html non flaky
: Make content/events/test/test_bug534833.html non flaky
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks: FlakyTimeout
  Show dependency treegraph
 
Reported: 2011-04-19 04:51 PDT by Mounir Lamouri (:mounir)
Modified: 2011-04-21 11:55 PDT (History)
2 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.09 KB, patch)
2011-04-19 04:51 PDT, Mounir Lamouri (:mounir)
ehsan: review+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2011-04-19 04:51:20 PDT
Created attachment 526958 [details] [diff] [review]
Patch v1

Very likely the setTimeout() is even useless because focus() is -AFAIK- synchronous. Though, using the focus event is better.
Comment 1 Mounir Lamouri (:mounir) 2011-04-20 02:50:31 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/7dc525f97223

Note You need to log in before you can comment on or make changes to this bug.