Closed Bug 651105 Opened 10 years ago Closed 10 years ago

Alert:Prevent this page from creating dialogs does not work as expected

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 633154

People

(Reporter: wes, Unassigned)

Details

When a web page invokes alert many times, we get the option to suppress the alerts presented as a check box.

Checking this check box causes this exception to be thrown upon subsequent invocations of alert:

[08:46:01.304] uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindowInternal.alert]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: http://www.page.ca/~wes/test.html :: <TOP_LEVEL> :: line 8"  data: no]

This is *not* the behaviour that web developers expect.  We expect our code to continue running, with the alert boxes suppressed. Nobody wraps alert in try..catch blocks.
Component: XP Toolkit/Widgets: XUL → XUL Widgets
Product: Core → Toolkit
QA Contact: xptoolkit.xul → xul.widgets
OS: Mac OS X → All
Hardware: x86 → All
Version: 2.0 Branch → Trunk
This would seem to be a duplicate of bug 633154, which in turn refers to last two paragraphs of bug 61098 comment #209
mm. icky.

Does that look like what you're seeing, Wes? If so, please dupe this against the above-mentioned bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633154
You need to log in before you can comment on or make changes to this bug.