Closed Bug 651429 Opened 10 years ago Closed 10 years ago

timeout in browser_tapping.js browser-chrome test

Categories

(Firefox for Android Graveyard :: General, defect)

All
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(1 file)

Attached patch Patch v1Splinter Review
The test has a pan followed by a longtap. The longtap test times out for me (on desktop Linux Fennec) because the panning test starts a kinetic pan.

Patch watches for the PanFinished event, and also adds a timeout because the active property isn't reset on the Kinetic pan until after the event is dispatched.
Attachment #527203 - Attachment is patch: true
Attachment #527203 - Attachment mime type: application/octet-stream → text/plain
Attachment #527203 - Flags: review?(mark.finkle)
Attachment #527203 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 651554
Blocks: 650686
http://hg.mozilla.org/mozilla-central/rev/357593f3abbd
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Nine to go :)
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → wjohnston
You need to log in before you can comment on or make changes to this bug.