Last Comment Bug 651567 - nsMathMLmunderFrame.cpp:285:11: warning: unused variable 'xHeight'
: nsMathMLmunderFrame.cpp:285:11: warning: unused variable 'xHeight'
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 11:23 PDT by Daniel Holbert [:dholbert]
Modified: 2011-04-21 10:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (968 bytes, patch)
2011-04-20 11:23 PDT, Daniel Holbert [:dholbert]
karlt: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-04-20 11:23:35 PDT
Created attachment 527328 [details] [diff] [review]
fix

Filing bug on this warning:
> layout/mathml/nsMathMLmunderFrame.cpp:285:11: warning: unused variable 'xHeight

Looks like this variable has actually been unused since it was first added, back in the year 2000:
http://mxr.mozilla.org/firefox/source/layout/mathml/base/src/nsMathMLmunderFrame.cpp
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/layout/mathml/base/src&command=DIFF_FRAMESET&file=nsMathMLmunderFrame.cpp&rev2=1.10&rev1=1.9

GCC only recently started warning us about this, though, because this variable had been set by passing it as an outparam -- which looked like we were 'using' it -- up until zwol tweaked it to set it directly, in Bug 174055 part 6.

Attached patch kills the variable.
Comment 1 Daniel Holbert [:dholbert] 2011-04-21 10:23:32 PDT
pushed: http://hg.mozilla.org/mozilla-central/rev/48b26f2254f8

Note You need to log in before you can comment on or make changes to this bug.