Last Comment Bug 651578 - Aurora About Dialog channel switcher should have left-aligned, not centered text
: Aurora About Dialog channel switcher should have left-aligned, not centered text
Status: VERIFIED FIXED
[channel-switcher] [bugday-20110513]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 5 Branch
: All All
: -- normal (vote)
: Firefox 5
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 11:53 PDT by Jennifer Morrow [:Boriss] (UX)
Modified: 2011-05-13 10:12 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Screenshots: Left vs center-aligned aurora about dialog (screenshots courtesy of Asa) (553.40 KB, image/png)
2011-04-20 11:53 PDT, Jennifer Morrow [:Boriss] (UX)
no flags Details
patch (3.17 KB, patch)
2011-04-20 13:57 PDT, :Margaret Leibovic
no flags Details | Diff | Review
screenshot with patch (223.47 KB, image/png)
2011-04-20 13:57 PDT, :Margaret Leibovic
no flags Details
patch (flips buttons on osx) (3.53 KB, patch)
2011-04-20 14:13 PDT, :Margaret Leibovic
gavin.sharp: review+
Details | Diff | Review
patch for check-in (3.53 KB, patch)
2011-04-20 14:51 PDT, :Margaret Leibovic
bugzilla: approval‑mozilla‑aurora+
Details | Diff | Review

Description Jennifer Morrow [:Boriss] (UX) 2011-04-20 11:53:04 PDT
Created attachment 527339 [details]
Screenshots: Left vs center-aligned aurora about dialog (screenshots courtesy of Asa)

Currently, when users click the "change" link in the Firefox button's channel switcher, the text in the About Aurora Dialog box goes from left-aligned to center-aligned.

Firstly, we should never be actively changing alignment on a screen the user's currently interacting with.

Secondly, we should not be centering text in multiple-sentence paragraphs, ever.  Doing so requires the user's scanning gaze to begin at different starting points on each line.  It also produces an ugly jagged line effect on both sides of our text.

The channel switcher should remain left aligned, except for the Apply and Cancel buttons at the bottom, which should be right-aligned in Vista for consistency across the OS.
Comment 1 Asa Dotzler [:asa] 2011-04-20 12:11:30 PDT
-> rob (I think)
Comment 2 Asa Dotzler [:asa] 2011-04-20 12:20:23 PDT
maybe this: 

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/aboutDialog.xul

129           <vbox id="channelSelector">
130             <hbox pack="center" align="center">
131               <label>&channel.selector.start;</label>
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-20 12:22:49 PDT
This is Firefox specific ui so over to Firefox -> General since that is the component where bug 644517 implemented this ui.
Comment 4 :Margaret Leibovic 2011-04-20 13:57:12 PDT
Created attachment 527369 [details] [diff] [review]
patch

This also works in RTL.
Comment 5 :Margaret Leibovic 2011-04-20 13:57:42 PDT
Created attachment 527370 [details]
screenshot with patch
Comment 6 :Margaret Leibovic 2011-04-20 14:13:44 PDT
Created attachment 527374 [details] [diff] [review]
patch (flips buttons on osx)

This patch flips the button order on OSX, as per Boriss's request in #ux.
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-04-20 14:47:23 PDT
Comment on attachment 527374 [details] [diff] [review]
patch (flips buttons on osx)

I think you want XP_UNIX (which covers both Linux and Mac) rather than XP_MACOSX, which matches what we do for normal dialogs:
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/dialog.xml#17
Comment 8 :Margaret Leibovic 2011-04-20 14:51:06 PDT
Created attachment 527391 [details] [diff] [review]
patch for check-in
Comment 9 :Margaret Leibovic 2011-04-20 15:22:21 PDT
http://hg.mozilla.org/mozilla-central/rev/1bf036202718
Comment 10 :Margaret Leibovic 2011-04-20 17:06:41 PDT
Comment on attachment 527391 [details] [diff] [review]
patch for check-in

Asking for approval to land on aurora. This is a low risk appearance change that polishes the look of the channel switcher.
Comment 11 Alex Limi (:limi) — Firefox UX Team 2011-04-20 17:22:59 PDT
(In reply to comment #10)
> Comment on attachment 527391 [details] [diff] [review]
> patch for check-in
> 
> Asking for approval to land on aurora. This is a low risk appearance change
> that polishes the look of the channel switcher.

I'd like to see this backported too, especially since this is the first time people will see the channel switcher.
Comment 12 :Margaret Leibovic 2011-05-03 09:36:29 PDT
Landed on mozilla-aurora:

http://hg.mozilla.org/mozilla-aurora/rev/57bd0687fd1f
Comment 13 :Margaret Leibovic 2011-05-03 09:37:50 PDT
Updating target milestone to Firefox 5, since this will be in there now that it's in aurora.
Comment 14 :Margaret Leibovic 2011-05-04 14:55:35 PDT
Also marking as fixed for Firefox 5.
Comment 15 Stephanie Daugherty [:sdaugherty] 2011-05-13 10:08:50 PDT
verifying in  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0a2) Gecko/20110510 Firefox/5.0a2

Note You need to log in before you can comment on or make changes to this bug.