Running on mac with no cache, significantly speeds up page load times

VERIFIED FIXED in mozilla1.0

Status

()

VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: jrgmorrison, Assigned: gordon)

Tracking

({perf})

Trunk
mozilla1.0
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The page load timing tests <http://jrgm.mcom.com/page-loader/loader.pl> are
being run by twalker each weekday, and I'm posting the results to n.p.m.porkjockeys.

Today's Mac times improved by 50% overall, with a range of 19% to 64%
improvement (in other words it was twice as fast overall).

After trying to reproduce this on another (identical) Mac G4, and failing, I
looked at the profile on twalker's machine that was used to run the test.

Due to bug http://bugzilla.mozilla.org/show_bug.cgi?id=57463, for a
commercial build, due to an interaction with activation, the cache is not
created until the second time that you start the browser. After checking
the machine where twalker runs the test, this is the situation that he was
in.

The difference in page load times for today's Mac run is directly the result of
running without a cache.

I realize that all of this code is under rework, and you may choose to dup this
bug against a bug with a more concrete purpose. But, I couldn't not file a bug
on this observed behaviour :-]
(Reporter)

Comment 1

18 years ago
Followup: I tried this out on win2k (same CPU/MB as twalker's tests), and
the reduction is 22% overall (range from 10% to 38%) for win2k over a 
fast network.
(Assignee)

Comment 2

18 years ago
Are the faster load times for the 1st load of a page?  It would be interesting to 
compare the speeds on pages that are already cached.  The way the current cache 
is designed, I would expect it to be slower on cache misses because it has to 
perform a database lookup to determine if the requested URL has been cached yet.
(Reporter)

Comment 3

18 years ago
One note: in the tests run with the cache, we never get a cache hit, because 
the cycle of 40 urls has more images than the current 512-items-in-cache limit.

I looked at the results for a run on the Mac, and for the running-with-cache
tests, the first visit to a page doesn't appear to be distinctly different than
any other visit to a page. Sometimes it's fastest, sometimes slowest, and 
sometimes it's in the middle. 

For the running-with-no-cache, surprisingly, the first visit is consistently
the slowest (although in some cases the times are all almost identical among
all 5 samples (e.g., there is fastest or slowest).

Updated

18 years ago
Keywords: perf

Comment 4

18 years ago
Cache bugs to Gordon
Assignee: neeti → gordon
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 5

18 years ago
This was with the old cache.  The new cache has landed, and has new performance 
bugs.  Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
verified with commercial build from 04/09
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.