Closed Bug 651866 Opened 9 years ago Closed 8 months ago

Intermittent failure in image/test/reftest/gif/test_bug641198.html | image comparison (==)

Categories

(Core :: ImageLib, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: ehsan, Unassigned)

References

(Depends on 2 open bugs)

Details

(Keywords: intermittent-failure, Whiteboard: [test disabled on Android])

Attachments

(1 file)

Attached file Reftest failure log
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303397548.1303398230.5853.gz
Rev3 Fedora 12x64 mozilla-central opt test reftest on 2011/04/21 07:52:28

Reftest failure log attached.
I just filed bug 652238 on an abort in this same test, FWIW.
BTW: In comment 0 & 2, the testcase is blank, whereas in comment 3 it's got a green square.  (In all cases, the reference has a _blue_ square, the same size as the green square from comment 3.)
Assignee: nobody → netzen
Assignee: netzen → nobody
Summary: Intermittent failure in modules/libpr0n/test/reftest/gif/test_bug641198.html | image comparison (==) → Intermittent failure in image/test/reftest/gif/test_bug641198.html | image comparison (==)
Would seem the backout of bug 775965 (for crashes) has turned this permaorange.
(In reply to Ed Morley [:edmorley] from comment #164)
> Would seem the backout of bug 775965 (for crashes) has turned this
> permaorange.

A couple on unluckily placed greens (this isn't quite permaorange) made this seem the case, however the real range is actually:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3b46b03dff5c&tochange=d67c02074ced
Blocks: 685516
Whiteboard: [orange] → [orange][test disabled on Android]
azakai, as author of this top orange, do you have any ideas? :-)
It looks like something has truly broken here. Running the test locally (just running that html file in the directory it is in is enough) gives very different results in Nightly versus Aurora. Nightly looks like it is not animating - it just shows the first or last frame in each of the 4 times we change the images. In Aurora the right behavior is shown, we animate 2 frames in each, so 8 frames are shown.
I bisected that regression range for the visible regression mentioned in comment 207 (which is not necessarily identical to the tbpl permaorange, but likely is). The bad changeset is

102329:5c730c1f2274

changeset:   102329:5c730c1f2274
user:        Kyle Huey <khuey@kylehuey.com>
date:        Mon Aug 13 15:04:19 2012 -0700
summary:     Bug 697230: Part 1 - Centralize style image observers. r=bz
Whiteboard: [orange][test disabled on Android] → [test disabled on Android]
Depends on: 1120144
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3

The test was disabled, tracking status with bug 1120144.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.