Last Comment Bug 651926 - gfxPlatform::Init needs to crash rather than returning an error if it fails
: gfxPlatform::Init needs to crash rather than returning an error if it fails
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Zack Weinberg (:zwol)
:
:
Mentors:
Depends on:
Blocks: 651498
  Show dependency treegraph
 
Reported: 2011-04-21 11:34 PDT by Zack Weinberg (:zwol)
Modified: 2011-08-12 09:06 PDT (History)
24 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
patch (4.75 KB, patch)
2011-04-21 11:42 PDT, Zack Weinberg (:zwol)
jmuizelaar: review+
Details | Diff | Splinter Review
as will be checked in (4.67 KB, patch)
2011-04-24 17:36 PDT, Zack Weinberg (:zwol)
zackw: review+
Details | Diff | Splinter Review

Description Zack Weinberg (:zwol) 2011-04-21 11:34:54 PDT
+++ This bug was initially created as a clone of Bug #651498 +++
> As a side note, gfxPlatform::Init ought to crash rather than returning an error
> code -- even in production builds -- if anything fails to start up, because
> nothing checks for a null pointer return from gfxPlatform::GetPlatform, so
> we're going to crash anyway.  But this was already broken, so I think it should
> get its own bug.
Comment 1 Zack Weinberg (:zwol) 2011-04-21 11:42:47 PDT
Created attachment 527595 [details] [diff] [review]
patch

Thus.

Some of these may already be covered by infallible malloc but I don't feel like auditing them just now.
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-04-21 11:44:44 PDT
Comment on attachment 527595 [details] [diff] [review]
patch

Yes please.
Comment 3 Zack Weinberg (:zwol) 2011-04-24 17:34:50 PDT
This is done and bug 651498 isn't, so I'm switching the dependency around so this can land (it's only a textual dependency).
Comment 4 Zack Weinberg (:zwol) 2011-04-24 17:36:00 PDT
Created attachment 528043 [details] [diff] [review]
as will be checked in

only change is to remove said textual dependency.
Comment 5 Zack Weinberg (:zwol) 2011-04-24 20:14:48 PDT
http://hg.mozilla.org/mozilla-central/rev/2250bc3d0532
Comment 6 Virgil Dicu [:virgil] [QA] 2011-08-12 09:01:08 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0

Could you please provide a test case for this issue in order for it to be set to verified Fixed?
Comment 7 Zack Weinberg (:zwol) 2011-08-12 09:06:13 PDT
This changed how promptly we crash under conditions that should never actually occur.  I do not believe a test case is feasible.

Note You need to log in before you can comment on or make changes to this bug.