Last Comment Bug 651947 - Build error on Windows in winEmbed.cpp:171 - missing type specifier - int assumed
: Build error on Windows in winEmbed.cpp:171 - missing type specifier - int ass...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on:
Blocks: 642795 653432
  Show dependency treegraph
 
Reported: 2011-04-21 12:35 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2011-05-11 11:35 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
patch (1.19 KB, patch)
2011-04-28 09:50 PDT, Mark Finkle (:mfinkle) (use needinfo?)
benjamin: review+
benjamin: approval‑mozilla‑aurora+
Details | Diff | Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2011-04-21 12:35:06 PDT
I'm getting this build error on Windows.

c:/mozilla-build/python/python2.6.exe -O c:/mozilla-build/fennec_trunk2/build/cl
.py cl -FowinEmbed.obj -c   -DXPCOM_GLUE -DXPI_NAME=winembed -DOSTYPE=\"WINNT6.1
\" -DOSARCH=WINNT -I/c/mozilla-build/fennec_trunk2/embedding/tests/winEmbed -I/c
/mozilla-build/fennec_trunk2/embedding/tests/winEmbed -I. -I../../../dist/includ
e -I../../../dist/include/nsprpub  -Ic:/mozilla-build/fennec_trunk2/_fennec/xulr
unner/dist/include/nspr -Ic:/mozilla-build/fennec_trunk2/_fennec/xulrunner/dist/
include/nss         -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd48
00  -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -O1 -MD            -FI ../../../
dist/include/mozilla-config.h -DMOZILLA_CLIENT /c/mozilla-build/fennec_trunk2/em
bedding/tests/winEmbed/winEmbed.cpp
winEmbed.cpp
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(171) : erro
r C4430: missing type specifier - int assumed. Note: C++ does not support defaul
t-int
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(171) : erro
r C2146: syntax error : missing ';' before identifier 'vr'
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(171) : erro
r C2065: 'vr' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(171) : erro
r C2059: syntax error : '{'
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(171) : erro
r C2143: syntax error : missing ';' before '{'
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(176) : erro
r C2143: syntax error : missing ';' before '}'
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(179) : erro
r C2065: 'self' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(179) : erro
r C2065: 'self' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(179) : erro
r C2070: ''unknown-type'': illegal sizeof operand
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(180) : erro
r C2065: 'lastslash' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(180) : erro
r C2065: 'xpcomPath' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(181) : erro
r C2065: 'lastslash' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(184) : erro
r C2065: 'lastslash' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(190) : erro
r C2065: 'lastslash' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(212) : erro
r C2065: 'lastslash' : undeclared identifier
c:/mozilla-build/fennec_trunk2/embedding/tests/winEmbed/winEmbed.cpp(220) : erro
r C2065: 'lastslash' : undeclared identifier
make[7]: *** [winEmbed.obj] Error 2
make[7]: Leaving directory `/c/mozilla-build/fennec_trunk2/_fennec/xulrunner/emb
edding/tests/winEmbed'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/c/mozilla-build/fennec_trunk2/_fennec/xulrunner/emb
edding/tests'
make[5]: *** [libs_tier_app] Error 2
make[5]: Leaving directory `/c/mozilla-build/fennec_trunk2/_fennec/xulrunner'
make[4]: *** [tier_app] Error 2
make[4]: Leaving directory `/c/mozilla-build/fennec_trunk2/_fennec/xulrunner'
make[3]: *** [default] Error 2
make[3]: Leaving directory `/c/mozilla-build/fennec_trunk2/_fennec/xulrunner'
make[2]: *** [realbuild] Error 2
make[2]: Leaving directory `/c/mozilla-build/fennec_trunk2'
make[1]: *** [realbuild] Error 2
make[1]: Leaving directory `/c/mozilla-build/fennec_trunk2'
make: *** [build] Error 2

mw22@MW22-PC /c/mozilla-build/fennec_trunk2
$

This is my .mozconfig file:
# Options for client.mk.
mk_add_options MOZ_BUILD_PROJECTS="xulrunner mobile"
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/_fennec

# needed to fix problem with Vista SDK
ac_add_options --disable-accessibility

ac_add_options --disable-activex 
ac_add_options --disable-activex-scripting 


Backing out the patch from bug 642795 fixes the build issue.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-04-28 09:50:23 PDT
Created attachment 528886 [details] [diff] [review]
patch

Made some changes to get the file to compile
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-02 11:09:52 PDT
pushed:
http://hg.mozilla.org/mozilla-central/rev/e36c9820debd
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-04 21:10:13 PDT
We are not making any Windows XULRunner 5.0 builds because of this bug. We fixed this for XULRunner 6 by landing on trunk. Asking to push to aurora so we have Windows XULRunner builds for 5.0
Comment 4 Benjamin Smedberg [:bsmedberg] 2011-05-05 05:54:47 PDT
I don't think release drivers need to track this, but I'll approve it as NPODB.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-07 13:19:35 PDT
pushed to aurora:
http://hg.mozilla.org/releases/mozilla-aurora/rev/087c1256b84d
Comment 6 Johnathan Nightingale [:johnath] 2011-05-11 11:35:30 PDT
(In reply to comment #5)
> pushed to aurora:
> http://hg.mozilla.org/releases/mozilla-aurora/rev/087c1256b84d

should be status-firefox5:fixed then, ya? Presuming as much and marking it, holler if I'm lying.

Note You need to log in before you can comment on or make changes to this bug.