Last Comment Bug 652034 - Firefox 4 hides/reduces the text area of popular Cbox's chatboxes (HTML/Ajax chat) after restarting the browser
: Firefox 4 hides/reduces the text area of popular Cbox's chatboxes (HTML/Ajax ...
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://kanon81.cbox.ws/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 18:52 PDT by Loic
Modified: 2011-05-06 01:49 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Loic 2011-04-21 18:52:55 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

Firefox 4 is breaking the text area of popular Cbox's chatboxes (HTML/Ajax chat, see the website http://www.cbox.ws/ ).

If the browser is closed with a tab displaying a Cbox's chatbox, at the time of the next start, Firefox hides or reduces the text area (a zone to enter a nickname, email/URL and message).

Refreshing the page doesn't fix the broken text area.
The user needs to revalidate the website URL in the URL bar to fix the bad rendering.

Tested with new and old profiles, all cookies deleted or not, bug still present.
Tested on a chatbox hosted on Cbox.ws servers or personal server, bug present.

Works with Firefox 3.6.16 (and earlier versions) and various OSes (XP SP3/Vista SP2). 

Reproducible: Always

Steps to Reproduce:
1. Open a tab with a Cbox's chatbox (like http://kanon81.cbox.ws/ )
2. Be sure the text area on the bottom is present (fields to enter nickname/email/message)
3. Close Firefox with the tab open
4. Restart Firefox and look at the tab
Actual Results:  
Firefox 4 is breaking the text area after restarting it.

Example with the chatbox http://kanon81.cbox.ws/ (you can search "cbox.ws" on Google to find other examples of chats):
* fields of text area are reduced, see http://i54.tinypic.com/15rfnm1.png
* complete text area is missing, see http://i52.tinypic.com/291fakx.png

Expected Results:  
Firefox 4 should display the text area of Cbox's chatbox after restarting.
Comment 1 Alice0775 White 2011-04-21 20:39:36 PDT
This was fixed on Aurora5.0a2 and Nightly6.0a1.

Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fb507e8752fe&tochange=ee2e22296d3c
Fixed by:
ee2e22296d3c	Olli Pettay — Bug 632835 - Firefox doesn't pass iframe test from bug 363109 correctly, r=bz
Comment 2 Loic 2011-04-21 23:57:17 PDT
Thanks for the quick response but your details are too technical for me. So if Aurora fixes the bug, I will believe you.
Comment 3 Mounir Lamouri (:mounir) 2011-05-02 05:58:28 PDT
Based on comment 1, I'm assuming the bug is fixed. Could you reopen if you can still reproduce the bug on Aurora (this is the testing version for Firefox 5).

You can download Aurora here:
https://www.mozilla.com/firefox/channel/
Comment 4 Loic 2011-05-02 08:58:45 PDT
Hello Mounir,
I installed and tested the latest Aurora version (5.0a2), fresh profile.

I observed that only a part of the bug is fixed. Now Aurora is able to display completely the text area after a reboot but its fields (name/email/message) are shorten like in my previous example: http://i54.tinypic.com/15rfnm1.png

Anyway I'm not able to know if the remaining part of this bug is on Cbox's side (script error) or due to the browser. I will contact Cbox's devs too.
Comment 5 Mounir Lamouri (:mounir) 2011-05-02 14:30:44 PDT
Feel free to reopen this bug if the issue comes from us.
Comment 6 Simona B [:simonab ] -PTO- back Sept 5th 2011-05-06 01:49:18 PDT
Verified on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110505 Firefox/6.0a1

Note You need to log in before you can comment on or make changes to this bug.