Closed Bug 652040 Opened 12 years ago Closed 10 years ago

Refactor tabs from other computers into panorama

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: faaborg, Unassigned)

References

(Depends on 1 open bug)

Details

Currently we have two competing interfaces for accessing groups of tabs, one based on physical machine (sync's Tabs From other Computers), and one based on the user's activity (Panorama).

This bug covers the following changes (each of which is probably large enough to be its own dependent bug):

1) Syncing panorama groups across all devices

2) Providing the same set of panorama groups on every desktop/laptop computer (so that tabs are organized based on activity, instead of based on physical machine)

3) Creating special panorama groups for the user's mobile device (since users are more likely to want a mobile specific tab set, and so that they can easily copy a tab over to their mobile device).

4) Removing the command "Tabs from other Computers"
(In reply to comment #0)
> This bug covers the following changes (each of which is probably large enough
> to be its own dependent bug):
> 
> 1) Syncing panorama groups across all devices

Bug 589336.
Depends on: 589336
Target Milestone: --- → Future
I think we should consider that users may want to keep their browsing state on different computers different. For example, the most common multi-computer scenario is covered-ish by faaborg's #3, but the second most common is probably a work computer/home computer situation, which almost certainly calls for different tab states.
(In reply to comment #3)
> I think we should consider that users may want to keep their browsing state
> on different computers different. For example, the most common
> multi-computer scenario is covered-ish by faaborg's #3, but the second most
> common is probably a work computer/home computer situation, which almost
> certainly calls for different tab states.

to be clear, I still want to sync tabs across computers, but I don't want them to force complete synchronicity of which tab group i'm in, etc. I actually pretty much like the "tabs from other computers" approach, but perhaps we can put tab groups in *there*
I think you've got it somewhat confused, there was never a plan to make it so that if you open a tab on device 1 it's automatically open on device 2 and device 3. However the plan is that if you open a tab on device 1, you can go into Panorama and access that tab via device 2 and device 3. This is about how Tabs from other computers is presented and the current approach doesn't fit with the rest of the firefox experience, hence the move to fold it into panorama.
Did this die?
This feature is currently not fully specified nor is it currently on the Sync road map (https://wiki.mozilla.org/Services/Roadmaps/Sync/Client/Sequence). So, it's stalled.
Not dead, but certainly not this year.
Did something change? So eager to see this feature fledged on my ff!
It continues to not be on the roadmap. Though I expect should someone have the necessary time and ability to make a patch, it would be graciously reviewed (within a two week period) and could make it's way onto the nightly channel shortly after.
I am very much interested in contributing to make panorama better. Please guide me so that I can try to contribute something in this respect.
The feel of about:sync-tabs is clunky and brings the browser to a halt every single time I load the page. I know some work is planned in bug 662664 which will negate that. It'd be a real shame if this bug got left behind.
:Optimizer called for help on this one, does anybody know who to contact?
Contact as in ?
(In reply to Girish Sharma [:Optimizer] from comment #11)
> Please guide me so that I can try to contribute something in this respect.

Looks like you need a mentor, don't you?
(In reply to Florian Bender from comment #15)
> (In reply to Girish Sharma [:Optimizer] from comment #11)
> > Please guide me so that I can try to contribute something in this respect.
> 
> Looks like you need a mentor, don't you?

Oh sure.
Originally it would've been between philikon and asa IIRC. The problem is, that while now you have rnewman who can help you with the services bit. Panorama/Tab Candy seems to have become an orphan. Nonetheless, added a bunch of people from the wiki.
If this is  implemented, I hope it be in addition to the current interface. With Panorama hidden by default it is even less discoverable than History > Tabs from other computers.  Forcing users to make Panorama visible so they can use a feature of Sync doesn't seem like good UX.  Besides, aren't we leaning towards the Push Tab to device model?
There was a lot written about how having so many ways to access tabs isn't great UX at all. The Panorama model is great for dealing with masses of tabs and unifying the Mozilla approach will be a huge win for everyone. Having this in addition to, rather than the default method of handling tabs would only lead to further confusion and failure of adoption. Tabs from Other Computers in it's current list like iteration isn't great for users.
I don't think this is in a place that's great for mentoring, unless you've got a lot of time and sway with product drivers to reach consensus on the future of tabs and groups.
Depends on: 769744
Blocks: 651817
No longer blocks: 651817
I'm going to close this as WONTFIX at the end of the year unless Asa tells me otherwise :D
Flags: needinfo?(asa)
Keywords: productwanted
Whiteboard: [closeme 2012-12-30]
Target Milestone: Future → ---
Please wontfix. The Product Team is opposed to further significant investment in Panorama.
Flags: needinfo?(asa)
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: productwanted
Resolution: --- → WONTFIX
Whiteboard: [closeme 2012-12-30]
Depends on: 865594
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.