Last Comment Bug 652178 - FIREFOX 4 not printing from ANCESTRY.com correctly
: FIREFOX 4 not printing from ANCESTRY.com correctly
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: mozilla6
Assigned To: David Baron :dbaron: ⌚️UTC-10
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 652929
  Show dependency treegraph
 
Reported: 2011-04-22 11:47 PDT by EMERY HOVERMALE
Modified: 2011-07-28 06:35 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Sample of incorrect FF4 output provided via email (283.04 KB, image/jpeg)
2011-04-22 20:48 PDT, Tim (fmdeveloper)
no flags Details
Sample of "correct" AOL output provided via email (768.93 KB, image/jpeg)
2011-04-22 20:49 PDT, Tim (fmdeveloper)
no flags Details
Minimalish testcase (398 bytes, text/html)
2011-04-25 20:32 PDT, Boris Zbarsky [:bz] (still a bit busy)
no flags Details
patch (6.76 KB, patch)
2011-04-25 23:44 PDT, David Baron :dbaron: ⌚️UTC-10
roc: review+
Details | Diff | Splinter Review

Description EMERY HOVERMALE 2011-04-22 11:47:12 PDT
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Everything was perfect when I was on ANCESTRY.COM . Switched to MOZZILA 4 yesterday & now I cant print 2 or three page documents correctly. Quality is fine but it reverses the pages. Dont know how to explain this but it prints most info on page 2 and whatever is left on page 1. Switched to AOL. I can print fine on AOL but they dont have copy & paste  & memory for repeats on the site.

Reproducible: Always

Steps to Reproduce:
1.go to ANCESTRY.com
2.try to print 2 or more pages
3.prints pages in reverse--Main info on 2nd page whatever is left on 1st page
Actual Results:  
printed pages are not usable

Expected Results:  
normally it prints second page first , which it does but instead of starting where the first page leaves off it starts from bottom of sheet , fills 2nd sheet then prints whats left on 1st sheet
Comment 1 Tim (fmdeveloper) 2011-04-22 16:52:37 PDT
Does the page appear correctly in Print Preview? Can you attach a PDF or scan of the output and attach to this bug?
Comment 2 Daniel Holbert [:dholbert] 2011-04-22 17:16:32 PDT
The first longish page I ran across (~4 pages) prints correctly (or at least, it shows up correctly in print-preview):
http://search.ancestry.com/iexec/?htx=List&dbid=6224
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-04-22 18:24:01 PDT
Emery, can you link to a particular page that's printing incorrectly for you?
Comment 4 Tim (fmdeveloper) 2011-04-22 20:48:52 PDT
Created attachment 527911 [details]
Sample of incorrect FF4 output provided via email
Comment 5 Tim (fmdeveloper) 2011-04-22 20:49:38 PDT
Created attachment 527912 [details]
Sample of "correct" AOL output provided via email
Comment 6 EMERY HOVERMALE 2011-04-25 18:38:33 PDT
Sent you two ways to link my site on ANCESTRY.com Have heard no more . Whats the status now.
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2011-04-25 20:09:09 PDT
OK, so I tested with the provided login+password.  What I see happening is that the header with the person's name and birth/death dates prints on page 1.  Then the timeline prints on page 2.

In 3.6, the timeline and "Family Members" over on the right print on page 1 below the header, while "Source information" prints on page 2.

Looking into that.
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2011-04-25 20:32:12 PDT
Created attachment 528257 [details]
Minimalish testcase
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2011-04-25 20:33:48 PDT
David, this looks like a float printing issue....

Emery, thank you for the login information!  Now that we have a small testcase for this, we shouldn't need to log in with your credentials anymore.
Comment 10 David Baron :dbaron: ⌚️UTC-10 2011-04-25 21:04:14 PDT
For some reason the clear is causing us to push the entire outer div to page 2.  My first guess is that we need to unset mIsTopOfPage for clear, but I haven't looked at this code for a while...
Comment 11 David Baron :dbaron: ⌚️UTC-10 2011-04-25 21:25:18 PDT
Seems like, for some reason, the div with 'clear: both' doesn't get pushed, which makes its parent nscoord_MAX tall, which forces the parent to get pushed.
Comment 12 David Baron :dbaron: ⌚️UTC-10 2011-04-25 22:01:39 PDT
http://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/a89943274093/push-for-clear fixes this bug, but it causes layout/reftests/printing/381497-f.html to only produce one page rather than two.
Comment 13 David Baron :dbaron: ⌚️UTC-10 2011-04-25 23:44:59 PDT
Created attachment 528273 [details] [diff] [review]
patch
Comment 14 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-04-26 00:07:31 PDT
Comment on attachment 528273 [details] [diff] [review]
patch

Review of attachment 528273 [details] [diff] [review]:
Comment 15 David Baron :dbaron: ⌚️UTC-10 2011-04-28 10:26:21 PDT
https://hg.mozilla.org/mozilla-central/rev/ff87496ea7fc
Comment 16 EMERY HOVERMALE 2011-04-28 13:40:48 PDT
Hovermale 2000@aol.com--Just tried to print--still the sme results. Will not print 2 page or more correctly
Comment 17 Daniel Holbert [:dholbert] 2011-04-28 13:47:56 PDT
(In reply to comment #16)
> Hovermale 2000@aol.com--Just tried to print--still the sme results

That's expected, assuming you're running Firefox 4. The fix referenced in in comment 15 was checked into on our development trunk (the code that will be released as Firefox 6 in a few months).
Comment 18 Simona B [:simonab ] 2011-07-28 06:35:05 PDT
Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

Verified issue on Win XP, Windows 7, Mac OS X 10.6 and Ubuntu using the test case from Comment Comment 8.

Setting resolution to VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.