Last Comment Bug 652192 - Remove layout/html
: Remove layout/html
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla6
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 12:29 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-05-08 12:42 PDT (History)
9 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Diffstat (164.67 KB, text/plain)
2011-04-22 12:33 PDT, :Ms2ger (⌚ UTC+1/+2)
dbaron: review+
Details

Description :Ms2ger (⌚ UTC+1/+2) 2011-04-22 12:29:45 PDT
Having non-automated tests that nobody runs only serve to confuse people, and they will be in the history if anybody ever wants to do something about it.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-04-22 12:33:31 PDT
Created attachment 527833 [details]
Diffstat

Patch is too big to attach, so I'll just ask for review on the diffstat
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-04-22 16:54:27 PDT
So we're giving up on HTML finally?  Woo!

On a serious note, why aren't we converting these to automated tests?
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-04-23 01:00:28 PDT
It would certainly be nice if someone stepped up to do that, but I don't see it happening. In any case, if such a hero would appear, he can always find these tests in the history.
Comment 4 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-04-23 10:18:03 PDT
The reason I've been hesitant to delete them in the past is that I do want them to be converted to automated tests...
Comment 5 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-04-30 12:43:59 PDT
Comment on attachment 527833 [details]
Diffstat

I suppose there's not particularly more value in converting the things that happened to be checked in here than anything else in bugzilla, so r=dbaron.
Comment 6 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-04-30 12:46:50 PDT
Give other people a few days to object, though.  (Maybe send email to dev-tech-layout too?)
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-04-30 23:03:11 PDT
Works for me.
Comment 8 Bernd 2011-05-01 00:14:10 PDT
I share Davids wish to convert them but the source can be easily retrieved otherwise. r+
Comment 9 :Ms2ger (⌚ UTC+1/+2) 2011-05-08 12:42:10 PDT
Didn't get any comments on the newsgroup, so I went ahead:

http://hg.mozilla.org/mozilla-central/rev/5991f0ec6b34

Note You need to log in before you can comment on or make changes to this bug.