Last Comment Bug 652299 - Remove unnecessary character conversion in CreateNPAPIPlugin
: Remove unnecessary character conversion in CreateNPAPIPlugin
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Makoto Kato [:m_kato]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 19:55 PDT by Makoto Kato [:m_kato]
Modified: 2011-05-02 03:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.25 KB, patch)
2011-04-22 19:55 PDT, Makoto Kato [:m_kato]
benjamin: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-04-22 19:55:09 PDT
Created attachment 527907 [details] [diff] [review]
fix

It is unnecessary to get nsIPlatformCharset and convert from UTF8 to Native due to Mac OS X only.
Comment 1 Makoto Kato [:m_kato] 2011-05-02 03:01:02 PDT
http://hg.mozilla.org/mozilla-central/rev/d761dc1a15f5

Note You need to log in before you can comment on or make changes to this bug.