If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

place:folder=-1 returns a non-empty result

VERIFIED FIXED in mozilla6

Status

()

Toolkit
Places
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: ithinc, Assigned: mak)

Tracking

({regression})

Trunk
mozilla6
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [places-next-wanted][fixed-in-places])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110423 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110423 Firefox/6.0a1

From the latest nightly build, "place:folder=-1" query returns non-empty result, is it intended?


Reproducible: Always
(Assignee)

Comment 1

7 years ago
what does it contain?
(Assignee)

Updated

7 years ago
Component: Bookmarks & History → Places
Product: Firefox → Toolkit
QA Contact: bookmarks → places
(Assignee)

Comment 2

7 years ago
I suppose a regression from bug 641074, we should return a valid result, but empty.
Blocks: 641074
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 3

7 years ago
The result seems the History items. I'm not sure. You may create a bookmark for "place:folder=-1" to have a test.
(Assignee)

Updated

7 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Whiteboard: [places-next-wanted]
(Assignee)

Updated

7 years ago
Summary: Why "place:folder=-1" query returns non-empty result? → place:folder=-1 returns a non-empty result
(Assignee)

Comment 4

7 years ago
Created attachment 528773 [details] [diff] [review]
patch v1.0
Attachment #528773 - Flags: review?(dietrich)
(Assignee)

Updated

7 years ago
Flags: in-testsuite?
(Reporter)

Comment 5

7 years ago
Note that although "place:folder=-1" returns non-empty result, "place:folder=-2" works as expected. Strange!
(Assignee)

Comment 6

7 years ago
I know, -1 is a special value we use for "not-bookmarked", and that's why it works differently. The above patch should fix that and also make it faster.
Comment on attachment 528773 [details] [diff] [review]
patch v1.0

Patch looks fine. Is the warning really necessary?
Attachment #528773 - Flags: review?(dietrich) → review+
(Assignee)

Comment 8

7 years ago
(In reply to comment #7)
> Comment on attachment 528773 [details] [diff] [review]
> patch v1.0
> 
> Patch looks fine. Is the warning really necessary?

I want to be sure that we don't hit this path in tests (unless wanted), otherwise the written test would be garbage.
(Assignee)

Comment 9

7 years ago
http://hg.mozilla.org/projects/places/rev/e7c50e928098
Whiteboard: [places-next-wanted] → [places-next-wanted][fixed-in-places]
(Assignee)

Comment 10

7 years ago
http://hg.mozilla.org/mozilla-central/rev/e7c50e928098
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla6
(Reporter)

Comment 11

7 years ago
Verified with Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110430 Firefox/6.0a1.

But what does "place:folder=FOOBAR" mean? It returns the same result as "place:folder=-1" did.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

7 years ago
(In reply to comment #11)
> But what does "place:folder=FOOBAR" mean? 

In this case, the query doesn't parse because FOOBAR means nothing, so a generic history query is created, that's by design (even if surprising).
You need to log in before you can comment on or make changes to this bug.