Last Comment Bug 652385 - nsLayoutStyleSheetcache has odd destructor
: nsLayoutStyleSheetcache has odd destructor
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: P5 normal (vote)
: mozilla6
Assigned To: David Baron :dbaron: ⌚️UTC-7
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-23 19:58 PDT by David Baron :dbaron: ⌚️UTC-7
Modified: 2011-04-28 10:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.62 KB, patch)
2011-04-23 19:58 PDT, David Baron :dbaron: ⌚️UTC-7
bzbarsky: review+
Details | Diff | Splinter Review

Description David Baron :dbaron: ⌚️UTC-7 2011-04-23 19:58:28 PDT
Created attachment 527977 [details] [diff] [review]
patch

nsLayoutStyleSheetCache has a destructor that duplicates the work that its static shutdown method does, but incorrectly (since it doesn't release the pointers).  The destructor should just be removed, since the shutdown method nulls out both pointers with its NS_RELEASE.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-04-25 12:03:53 PDT
Comment on attachment 527977 [details] [diff] [review]
patch

r=me
Comment 2 David Baron :dbaron: ⌚️UTC-7 2011-04-28 10:26:08 PDT
https://hg.mozilla.org/mozilla-central/rev/d656c5e38d83

Note You need to log in before you can comment on or make changes to this bug.