Last Comment Bug 652399 - Using system libjpeg should disable building embedded libjpeg-turbo
: Using system libjpeg should disable building embedded libjpeg-turbo
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla7
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on: 675568
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-24 00:28 PDT by Mike Hommey [:glandium]
Modified: 2011-08-01 16:40 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (753 bytes, patch)
2011-04-24 00:28 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Review
Patch v2 (1.16 KB, patch)
2011-05-02 05:56 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-04-24 00:28:14 PDT
Created attachment 527985 [details] [diff] [review]
Patch

cf. summary
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-04-28 10:02:08 PDT
Comment on attachment 527985 [details] [diff] [review]
Patch

Review of attachment 527985 [details] [diff] [review]:

r=me
Comment 2 Mike Hommey [:glandium] 2011-05-02 05:56:08 PDT
Created attachment 529453 [details] [diff] [review]
Patch v2

I don't know how I thought the previous patch was okay, but it turns out MOZ_LIBJPEG_TURBO is set to 1 unconditionally after it was set to nothing by the patch, so it was pointless.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-05-06 06:25:25 PDT
Comment on attachment 529453 [details] [diff] [review]
Patch v2

Review of attachment 529453 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Mike Hommey [:glandium] 2011-05-08 22:43:50 PDT
http://hg.mozilla.org/mozilla-central/rev/dc9cf2842794
Comment 5 Justin Lebar (not reading bugmail) 2011-08-01 11:26:30 PDT
Backed out on beta (FF6), a=legneato, due to bug 675568.
http://hg.mozilla.org/releases/mozilla-beta/rev/f83956d23621
Comment 6 Justin Lebar (not reading bugmail) 2011-08-01 16:40:51 PDT
The push from comment 5 was to the relbranch, not the default branch. Properly backed out on beta: http://hg.mozilla.org/releases/mozilla-beta/rev/eeabcaa28b68

Note You need to log in before you can comment on or make changes to this bug.