Using system libjpeg should disable building embedded libjpeg-turbo

RESOLVED FIXED in mozilla7

Status

RESOLVED FIXED
8 years ago
9 months ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
mozilla7
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Created attachment 527985 [details] [diff] [review]
Patch

cf. summary
Attachment #527985 - Flags: review?(ted.mielczarek)
Assignee: nobody → mh+mozilla
Comment on attachment 527985 [details] [diff] [review]
Patch

Review of attachment 527985 [details] [diff] [review]:

r=me
Attachment #527985 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 2

8 years ago
Created attachment 529453 [details] [diff] [review]
Patch v2

I don't know how I thought the previous patch was okay, but it turns out MOZ_LIBJPEG_TURBO is set to 1 unconditionally after it was set to nothing by the patch, so it was pointless.
Attachment #527985 - Attachment is obsolete: true
Attachment #529453 - Flags: review?(ted.mielczarek)
Comment on attachment 529453 [details] [diff] [review]
Patch v2

Review of attachment 529453 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #529453 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/dc9cf2842794
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla6

Updated

7 years ago
Depends on: 675568
Target Milestone: mozilla6 → mozilla7
The push from comment 5 was to the relbranch, not the default branch. Properly backed out on beta: http://hg.mozilla.org/releases/mozilla-beta/rev/eeabcaa28b68

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.