Last Comment Bug 652517 - [OS/2] make package fails to generate startupCache.zip
: [OS/2] make package fails to generate startupCache.zip
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 OS/2
: -- normal (vote)
: mozilla8
Assigned To: Walter Meinl
:
Mentors:
Depends on:
Blocks: 633645
  Show dependency treegraph
 
Reported: 2011-04-25 05:18 PDT by Walter Meinl
Modified: 2011-08-10 08:58 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch working with (pdk)sh (1.08 KB, patch)
2011-05-08 03:56 PDT, Walter Meinl
no flags Details | Diff | Splinter Review
change quotation marks (1.09 KB, patch)
2011-08-05 23:05 PDT, Walter Meinl
mh+mozilla: review+
Details | Diff | Splinter Review
updated for check-in (1.10 KB, patch)
2011-08-08 13:31 PDT, Walter Meinl
no flags Details | Diff | Splinter Review

Description Walter Meinl 2011-04-25 05:18:27 PDT
User-Agent:       Mozilla/5.0 (OS/2; Warp 4.5; rv:6.0a1) Gecko/20110425 Firefox/6.0a1
Build Identifier: 

[E:\mozbuild7\dist\firefox]set BEGINLIBPATH=..\..\DIST\bin;E:\usr\local441\lib;E:\usr\lib;E:\GLIBIDL\gcc335\lib;E:\PERL\lib;E:\MOZTOOLS;E:\EMX\dll;E:\python26; 

[E:\mozbuild7\dist\firefox]set LIBPATHSTRICT=T 

[E:\mozbuild7\dist\firefox]E:\MOZBUILD7\BROWSER\INSTALLER\..\..\DIST\BIN\XPCSHELL.EXE -g "" -f E:/hg-src/hg/mozilla-aurora/browser/installer/precompile_cache.js -e "populate_startupcache("omni.jar", "startupCache.zip");" 
SetGREDir failed.
unzip:  cannot find either startupCache.zip or startupCache.zip.zip.
make.exe[2]: *** [make-package] Error 9

Note "$$PWD" gets resolved to an empty string

exchanging "$$PWD" to "$(CURDIR)" resolves it to "$objdir/browser/installer" but then it fails with
E:\MOZBUILD1\BROWSER\INSTALLER\..\..\DIST\BIN\XPCSHELL.EXE -g E:/mozbuild1/browser/installer -f E:/hg-src/hg/comm-central/mozilla/browser/installer/precompile_cache.js -e "populate_startupcache("omni.jar", "startupCache.zip");"
-e:1: ReferenceError: omni is not defined


Reproducible: Always
Comment 1 Dave Yeo 2011-04-25 08:00:56 PDT
IIRC ash has a bug where $PWD is not set until a cd is issued, eg cd ./.
(pdk)sh.exe does not have this bug.
Comment 2 Walter Meinl 2011-04-25 10:27:18 PDT
(In reply to comment #1)
> IIRC ash has a bug where $PWD is not set until a cd is issued, eg cd ./.
> (pdk)sh.exe does not have this bug.

When I put PWD in brackets "$$(PWD)", the GreDir is setup properly. However still I see then 
-e:1: ReferenceError: omni is not defined (as if the "." in omni.jar is somehow taken as a delimiter)
Comment 3 Walter Meinl 2011-04-26 00:09:27 PDT
(In reply to comment #1)
> IIRC ash has a bug where $PWD is not set until a cd is issued, eg cd ./.
> (pdk)sh.exe does not have this bug.

(In reply to comment #2)
 
> When I put PWD in brackets "$$(PWD)", the GreDir is setup properly.
While this works with our ash.exe, it doesn't build on linux
You are right, the PWD problem is due to ash, with pdksh it gets resolved properly.
> However, still I see then 
> -e:1: ReferenceError: omni is not defined (as if the "." in omni.jar is somehow
> taken as a delimiter)
The second problem seems to be caused by quotation. It doesn't work with pdksh as well. But when I use single quotes for 'omni.jar', 'startupCache.zip' it works.
Comment 4 Walter Meinl 2011-05-08 03:56:06 PDT
Created attachment 530903 [details] [diff] [review]
patch working with (pdk)sh

as explained in comment#3
Comment 5 Walter Meinl 2011-08-05 23:05:04 PDT
Created attachment 551232 [details] [diff] [review]
change quotation marks

This works with ash (with a little workaround for the bug in ash) and ksh and sh
Comment 6 Walter Meinl 2011-08-08 13:31:13 PDT
Created attachment 551553 [details] [diff] [review]
updated for check-in

to apply cleanly after check-in 1762d5d119fb for bug674352
Comment 7 Justin Wood (:Callek) (Away until Aug 29) 2011-08-10 01:20:58 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/682ad2a5f003

Note You need to log in before you can comment on or make changes to this bug.