Allow nsIDOMGlobalPropertyInitializer to parent a property under window.navigator

RESOLVED DUPLICATE of bug 641552

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 641552
7 years ago
7 years ago

People

(Reporter: ddahl, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
It would be very handy if an nsIDOMGlobalPropertyInitializer could provide a property like "navigator" and the new nsIDOMGlobalProperty would become a child of navigator automatically. 

I'm not sure how involved this would be, or how difficult it might be to create a property under window.navigator.
(Reporter)

Updated

7 years ago
Blocks: 652021
(Reporter)

Updated

7 years ago
Blocks: 652653

Comment 1

7 years ago
if I am reading this correctly, i think it would have made orientation, geo, desktop notifications, and upcoming permissions a bit easier to implement
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> if I am reading this correctly, i think it would have made orientation, geo,
> desktop notifications, and upcoming permissions a bit easier to implement

yeah, just add a property like 

{ 
  // nsIDOMGlobalPropertyInitializer
  parent: "navigator" 

}

and presto, you get a navigator object
(Reporter)

Updated

7 years ago
No longer blocks: 652021, 652653
(Reporter)

Comment 3

7 years ago
According to jst, this is a bit of non-trivial work, via irc:

<jst> bug 652610 would take a bit of work, we'd need a new category, and the appropriate hooks etc on the navigator to initialize the new component etc when the right name is resolved
Dupe of bug 641552?
Yup, duping. And while this might not be trivial, it's not particularly hard either. Let's sort that out in bug 641552.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 641552
You need to log in before you can comment on or make changes to this bug.