Last Comment Bug 652753 - Remove listener and observer in head.js even if test is timed out
: Remove listener and observer in head.js even if test is timed out
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Hiroyuki Ikezoe (:hiro)
:
: Mike de Boer [:mikedeboer]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-25 23:33 PDT by Hiroyuki Ikezoe (:hiro)
Modified: 2011-05-12 03:36 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (3.66 KB, patch)
2011-04-25 23:33 PDT, Hiroyuki Ikezoe (:hiro)
paul: review+
Details | Diff | Splinter Review

Description Hiroyuki Ikezoe (:hiro) 2011-04-25 23:33:14 PDT
Created attachment 528271 [details] [diff] [review]
Proposed patch

waitForBrowserState and waitForSaveState use listener and observer but those are removed in its function. We should also use registerCleanupFunction in case of timeout.
Comment 1 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-05-10 15:21:10 PDT
Comment on attachment 528271 [details] [diff] [review]
Proposed patch

Patch looks good. Do you have any idea if there are cases where we're actually hitting this?
Comment 2 Hiroyuki Ikezoe (:hiro) 2011-05-10 16:00:04 PDT
It happened once on my local Windows XP VM, but at that time the VM was getting slow down due to unknown reason, and I do not remember which test case causes this, but anyway it happens if user runs tests which use waitForBrowserState or waitForSaveSatate on a slow machine. ;-)
Comment 3 Mounir Lamouri (:mounir) 2011-05-12 03:36:18 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/547d189ddfd9

Note You need to log in before you can comment on or make changes to this bug.