Last Comment Bug 652761 - ABORT: half open complete but no item: 'index != -1' with embedded src port 80000
: ABORT: half open complete but no item: 'index != -1' with embedded src port ...
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Patrick McManus [:mcmanus]
:
:
Mentors:
http://www.radiofunn.ro/
Depends on:
Blocks: 532972 651635
  Show dependency treegraph
 
Reported: 2011-04-26 02:23 PDT by Bob Clary [:bc:]
Modified: 2012-03-29 02:06 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
testcase (77 bytes, text/html)
2011-04-26 02:23 PDT, Bob Clary [:bc:]
no flags Details
fix out of range port v1 (2.09 KB, patch)
2011-04-26 07:44 PDT, Patrick McManus [:mcmanus]
honzab.moz: review+
Details | Diff | Splinter Review
fix out of range port v2 (2.25 KB, patch)
2011-04-28 12:37 PDT, Patrick McManus [:mcmanus]
mcmanus: review+
jpr: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Bob Clary [:bc:] 2011-04-26 02:23:00 PDT
Created attachment 528284 [details]
testcase

1. http://www.radiofunn.ro/
2. nsHttpConnectionMgr::nsHalfOpenSocket::~nsHalfOpenSocket() [nsHttpConnectionMgr.cpp : 1225 + 0x20]

<Embed type="application/x-mplayer2" src="http://www.example.com:80000">

mac,linux,winxp mozilla-central
Comment 1 Bob Clary [:bc:] 2011-04-26 02:25:37 PDT
bork! bork!
Comment 2 Patrick McManus [:mcmanus] 2011-04-26 05:23:17 PDT
I'll investigate this first thing.
Comment 3 Patrick McManus [:mcmanus] 2011-04-26 07:44:03 PDT
Created attachment 528310 [details] [diff] [review]
fix out of range port v1

The problem, as you may have surmised, is due to the port 80,000 in the example and an early failure to create the transport object.

fix attached, complete with test case.

this bug is on aurora too, I'll need to go read some archived mail/posts to figure out what to do about that.
Comment 4 Patrick McManus [:mcmanus] 2011-04-26 08:13:35 PDT
This is a trivial fix to an error path potential crash in the syn-retry FF5 feature - setting tracking flags to what I hope are appropriate values :)
Comment 5 Johnny Stenback (:jst, jst@mozilla.com) 2011-04-26 15:44:57 PDT
Let us know when we have a patch ready for approval. We're likely to approve a reviewed patch here, but we won't be tracking this.
Comment 6 Honza Bambas (:mayhemer) 2011-04-27 12:59:21 PDT
Comment on attachment 528310 [details] [diff] [review]
fix out of range port v1

I'd rather use RemoveElement and ignore its result here then.  It does the same but in more encapsulated way.  Also the code will be cleaner.

r=honzab with that.

Good catch.
Comment 7 Patrick McManus [:mcmanus] 2011-04-28 12:37:51 PDT
Created attachment 528930 [details] [diff] [review]
fix out of range port v2

update from review comment 6 - carry forward r=honzab
Comment 8 Patrick McManus [:mcmanus] 2011-04-28 14:46:53 PDT
http://hg.mozilla.org/mozilla-central/rev/3723e9c3557e
Comment 9 Patrick McManus [:mcmanus] 2011-04-29 06:07:15 PDT
http://hg.mozilla.org/mozilla-aurora/rev/c90cd210cad3

Note You need to log in before you can comment on or make changes to this bug.