Open Bug 652790 Opened 9 years ago Updated 8 years ago

Append profile name to WM_ROLE

Categories

(Firefox :: Shell Integration, enhancement)

All
Linux
enhancement
Not set

Tracking

()

UNCONFIRMED

People

(Reporter: chkappel, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/534.29 (KHTML, like Gecko) Chrome/12.0.735.0 Safari/534.29
Build Identifier: Mozilla Firefox 4.0

Generally the WM_ROLE can be used to address a specific window for many things like properties or placement. It would be really helpful, when Firefox appends the name of the currently used profile to the WM_ROLE.

I would appreciate a naming like 'browser-profilename' or something like that, that doesn't clash with other Firefox windows.

I will rely on the output of xprop in the actual and expected results boxes.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2.
3.

Actual Results:  
WM_WINDOW_ROLE(STRING) = "browser"

Expected Results:  
WM_WINDOW_ROLE(STRING) = "browser-profilename"
Reproduced with latest Nightly.
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110515 Firefox/6.0a1

$ xprop|grep WM_WINDOW_ROLE
WM_WINDOW_ROLE(STRING) = "browser"
Component: General → Shell Integration
QA Contact: general → shell.integration
Version: unspecified → Trunk
The relevant code doesn't have a concept of a profile name (because Firefox can be launched with -profile /path), and I don't want to accept the complexity that would be required to actually fix this.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
So because you cannot fetch the profile name from a given path the issue is just WONTFIX?

I really can't believe that there is a complexity at all, because you can happily set the WM_ROLE after the profile loading is complete and therefore you have the name of it.
Since --class (https://bugzil.la/496653) finally works again, why can't it be used with profiles from the profile manager? Can't be a solution to write my own profile manager at all..
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
You need to log in before you can comment on or make changes to this bug.