Test failure in testSoftwareUpdateAutoProxy (test2.js)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: aaronmt, Assigned: aaronmt)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-test-failure][needs-mozmill-1.5.4], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Test: test2.js
Module: testSoftwareUpdateAutoProxy
Error: Empty message
Platform: NT 5.1.2600, 6.1.7600, 6.0.6002, 5.0.2195, Linux Ubuntu 10.10 
Branch: default

http://mozmill-release.brasstacks.mozilla.com/#/general/failure?branch=6.0&test=%2FrestartTests%2FtestSoftwareUpdateAutoProxy%2Ftest2.js&func=testSoftwareUpdateAutoProxy
Would be good to know what error is visible in the Error Console in those cases. Also the assertJS calls could be moved to assert() for more descriptive failures.
We have log files located in the home/mozmill/ folder we could use to analyze the problem. Sadly only Ubuntu 64 showed this problem but the log file has been overwritten with the test-run of the 32bit build.
Depends on: 650646
The empty error message is because of bug 650646 and would need a new hotfix-1.5.x release.
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][needs-mozmill-1.5.4]
Aaron, do you have any update on this bug? Were you able to check it on Friday? Has it been started at the same time as bug 650646? Or are we able to get a failure message from before this change happened in the nightly build.
(Assignee)

Comment 5

8 years ago
Was unable to reproduce this bug on the reported platforms alongside the reported builds based off their change-sets. Currently testing with mozilla2.0 builds alongside Nightly builds and as well am not seeing any problems.

The reports generated for this issue do showcase an assert error from earlier April, that does not seem to happen daily, nor is it occurring during my testing here. See the report range below

http://mozmill-release.brasstacks.mozilla.com/#/general/failure?branch=All&platform=All&from=2011-04-01&test=%2FrestartTests%2FtestSoftwareUpdateAutoProxy%2Ftest2.js&func=testSoftwareUpdateAutoProxy
So it seems like we will have to wait until the dependency has been fixed. Thanks for the update Aaron.
The test failure on 4.0 could help us in-between I bet:
http://mozmill-release.brasstacks.mozilla.com/#/general/failure?branch=4.0&platform=Linux&from=2011-05-03&to=2011-05-10&test=%2FrestartTests%2FtestSoftwareUpdateAutoProxy%2Ftest2.js&func=testSoftwareUpdateAutoProxy

controller.assertJS: Failed for 'subject.currentPage == subject.noUpdatesFoundPage'

We should update it to use assert instead.
Aaron, can you please create patches for this test across default, aurora, and mozilla-2.0 which make use of assert instead of assertJS? We need more information for this kind of failure.
(Assignee)

Comment 9

8 years ago
Created attachment 532329 [details] [diff] [review]
Patch v1 - (default) [assert]

+ assertJS -> assert
Assignee: nobody → aaron.train
Status: NEW → ASSIGNED
Attachment #532329 - Flags: review?(hskupin)
Comment on attachment 532329 [details] [diff] [review]
Patch v1 - (default) [assert]

>- controller.assertJS("subject.isUpdateAllowed == true",
>-                     {isUpdateAllowed: update.allowed});
>+ controller.assert(function() {
>+  return update.allowed == true;
>+ }, "Update permissions - got " + "'" + update.allowed + "'" + 
>+   " expected 'true'");

There is no need for the '==' operator. Just remove it. Also please use two spaces as indentation.

>+   controller.assert(function () {
>+     return update.currentPage == softwareUpdate.WIZARD_PAGES.noUpdatesFound;
>+   }, "Update dialog wizard page - got " + "'" + update.currentPage + "'" + 
>+     " expected '" + softwareUpdate.WIZARD_PAGES.noUpdatesFound);

Triple operator please.

But finally I could imagine what's going wrong. At least in the last couple days. Due to the broken security certificate on allizom, we weren't always able to successfully update the build, because other processes were lingering around. So in those cases the update found pane is visible. We should better check for the non-error wizard page.
Attachment #532329 - Flags: review?(hskupin) → review-
(Assignee)

Comment 11

8 years ago
Created attachment 532402 [details] [diff] [review]
Patch v2 - (default) [assert]

assertJS -> assert, and waitForEval to waitFor
Attachment #532329 - Attachment is obsolete: true
Attachment #532402 - Flags: review?(hskupin)
Comment on attachment 532402 [details] [diff] [review]
Patch v2 - (default) [assert]

Please get it landed on all branches down to 2.0. Thanks.
Attachment #532402 - Flags: review?(hskupin) → review+
Aaron, any update on this bug?

Comment 15

7 years ago
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/15312605
(Assignee)

Comment 16

7 years ago
Unable to reproduce the failures reported across platforms locally. Strangely, it looks like these happened three days in a row last month and then went silent [1].

[1] http://mozmill-release.brasstacks.mozilla.com/#/functional/failure?branch=All&platform=All&from=2011-05-19&to=2011-07-08&test=%2FrestartTests%2FtestSoftwareUpdateAutoProxy%2Ftest2.js&func=testSoftwareUpdateAutoProxy

I'll reopen if they start occurring again this month.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.