Last Comment Bug 653086 - clean up editor configuration lines in a11y files
: clean up editor configuration lines in a11y files
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Trevor Saunders (:tbsaunde)
:
Mentors:
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2011-04-27 03:44 PDT by Trevor Saunders (:tbsaunde)
Modified: 2011-06-13 04:11 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
MAKE SURE EACH FILE IN ATK/ HAS BOTH VIM AND EMACS LINES SETUP FOR 2 SPACE INDENTS (33.78 KB, patch)
2011-04-27 03:48 PDT, Trevor Saunders (:tbsaunde)
surkov.alexander: review+
Details | Diff | Splinter Review
patch (34.59 KB, patch)
2011-05-27 15:50 PDT, Trevor Saunders (:tbsaunde)
fherrera: review+
Details | Diff | Splinter Review

Description Trevor Saunders (:tbsaunde) 2011-04-27 03:44:41 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110425 Firefox/6.0a1
Build Identifier: 

before we tart reindenting atk/ to use 2 space t indents instead of 4 we should change the editor configuration lines to use 2 spaces instead of 4.  Also while doing this outside of atk/ there where a few files that had no such lines and many others that only  had emacs ones, make sure all these files have ones for both vim and emacs.

Reproducible: Always
Comment 1 Trevor Saunders (:tbsaunde) 2011-04-27 03:48:08 PDT
Created attachment 528559 [details] [diff] [review]
MAKE SURE EACH FILE IN ATK/ HAS BOTH VIM AND EMACS LINES SETUP FOR 2 SPACE INDENTS
Comment 2 alexander :surkov 2011-04-27 03:53:40 PDT
Comment on attachment 528559 [details] [diff] [review]
MAKE SURE EACH FILE IN ATK/ HAS BOTH VIM AND EMACS LINES SETUP FOR 2 SPACE INDENTS

Review of attachment 528559 [details] [diff] [review]:

r=me
Comment 3 alexander :surkov 2011-04-27 07:26:57 PDT
landed - http://hg.mozilla.org/mozilla-central/rev/f9a978db8102
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-04-27 09:33:08 PDT
Thanks!
Comment 5 Ginn Chen 2011-05-16 00:32:07 PDT
It doesn't work for me.
I got
Error detected while processing modelines:
line    2:
E518: Unknown option: */

It works if I change
/* vim:expandtab:shiftwidth=2:tabstop=2: */
to
/* vim:expandtab:shiftwidth=2:tabstop=2:
 */
Comment 6 alexander :surkov 2011-05-20 01:06:41 PDT
Trevor, could you address comment #5 please?
Comment 7 Trevor Saunders (:tbsaunde) 2011-05-20 02:11:23 PDT
(In reply to comment #6)
> Trevor, could you address comment #5 please?

Yeah, I notice the same issue too, I  took a quick look and we had this issue  in some files before, and I ended up just spreading it around all of atk/ :(    https://developer.mozilla.org/En/Mozilla_Coding_Style_Guide suggests /* vim: set ts=2 et sw=2 tw=80: * which works for me, does it work for Ginn?
Comment 8 Trevor Saunders (:tbsaunde) 2011-05-27 15:50:42 PDT
Created attachment 535766 [details] [diff] [review]
patch

I used the vim configuration suggested in 
https://developer.mozilla.org/En/Developer_Guide/Coding_Style
Ginn Fernando does this work for you? it seems to work for me.
Comment 9 Trevor Saunders (:tbsaunde) 2011-06-13 04:11:08 PDT
landed http://hg.mozilla.org/mozilla-central/rev/78ad95eaf1f1

Note You need to log in before you can comment on or make changes to this bug.