Last Comment Bug 653119 - GCLI should have l10n functions to help localize both in the browser and in firefox
: GCLI should have l10n functions to help localize both in the browser and in f...
Status: RESOLVED FIXED
[best:1d, likely:2d, worst:2d]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: P2 normal (vote)
: ---
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
:
Mentors:
: 681914 (view as bug list)
Depends on:
Blocks: 653135 653139 GCLI-JS
  Show dependency treegraph
 
Reported: 2011-04-27 08:09 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-09-27 04:48 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-04-27 08:09:27 PDT
GCLI and maybe Ace need be l10n-ized. There will be different ways of achieving this in the browser and for the web. Pilot is an obvious way to allow both camps to be happy.

It is expected initially that the API will resemble the Firefox implementation.
Comment 1 Axel Hecht [:Pike] 2011-04-27 08:49:58 PDT
Is there a feature page for this?
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-04-27 10:46:57 PDT
(In reply to comment #1)
> Is there a feature page for this?

Not directly because pilot isn't a feature. It is a part of the graphical command line (https://wiki.mozilla.org/DevTools/Features/GCLI) which extends the web console.
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-03 03:10:17 PDT
The difficulty is in the breadth of the API, we only want to solve the problems we actually have not all possible l10n problems.

We are sure to need:

    var stringToDisplay = getLocalizedString('someKey');

We will also need some form of string interpolation:

    interpolate('the {sub} sat on the {obj}', { sub:'cat', obj:'mat' });

And *maybe* some pluralization:

    getLocalizedPluralizedString('someKey', 42);

I'm not expecting to need number / date / currency formatting, or weight / measure / timezone conversion.

I'm expecting that text direction and collation order are solved elsewhere.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-25 04:00:04 PDT
*** Bug 681914 has been marked as a duplicate of this bug. ***
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-09-27 04:48:34 PDT
The code for this bug is being checked in as part of bug 656666 and bug 656668. Discussion of this l10n effort should be directed to bug 656666.

Note You need to log in before you can comment on or make changes to this bug.