Last Comment Bug 653145 - move layout/xul/base/test/* mochitests to mochitest-chrome to avoid enablePrivileges
: move layout/xul/base/test/* mochitests to mochitest-chrome to avoid enablePri...
Status: RESOLVED FIXED
[specialpowers]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Joel Maher ( :jmaher)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 462483
  Show dependency treegraph
 
Reported: 2011-04-27 09:08 PDT by Joel Maher ( :jmaher)
Modified: 2011-06-09 15:07 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
move layout/xul/base/test/* from mochitest-plain -> chrome (1.0) (13.93 KB, patch)
2011-04-27 09:08 PDT, Joel Maher ( :jmaher)
ted: review+
Details | Diff | Splinter Review
move layout/xul/base/test/* from mochitest-plain -> chrome (2.0) (7.55 KB, patch)
2011-05-24 03:59 PDT, Joel Maher ( :jmaher)
bzbarsky: review+
trev.moz: review+
Details | Diff | Splinter Review

Description Joel Maher ( :jmaher) 2011-04-27 09:08:54 PDT
Created attachment 528605 [details] [diff] [review]
move layout/xul/base/test/* from mochitest-plain -> chrome (1.0)

in the move to remove enablePrivilege with specialPowers, we have found that many tests don't make sense as mochitest plain.  

If any of these tests should be mochitest-plain, please speak up.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-04-27 09:14:29 PDT
It's not clear to me that this makes sense for test_bug511075.html.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-04-27 09:15:33 PDT
Can you r? the original test author(s)? I don't have the domain knowledge to say whether moving them to chrome will break anything.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-05-09 08:55:19 PDT
Comment on attachment 528605 [details] [diff] [review]
move layout/xul/base/test/* from mochitest-plain -> chrome (1.0)

Review of attachment 528605 [details] [diff] [review]:
-----------------------------------------------------------------

The mechanical changes look fine. Please get review from a peer on these tests so we can ensure that you're not breaking anything the tests are intended to test.
Comment 4 Joel Maher ( :jmaher) 2011-05-24 03:59:30 PDT
Created attachment 534715 [details] [diff] [review]
move layout/xul/base/test/* from mochitest-plain -> chrome (2.0)

updated patch to remove test_resizer.xul (fails on osx and winxp) and test_splitter.xul (fails on winxp).  These are passing on try server.  I would like to get a review that these tests I am moving:
/layout/xul/base/test/test_bug381167.xhtml
/layout/xul/base/test/test_bug393970.xul
/layout/xul/base/test/test_bug477754.xul
/layout/xul/base/test/test_bug511075.html
/layout/xul/base/test/test_stack.xul

will still be testing the same functionality when run in the mochitest-chrome harness.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2011-05-24 07:59:04 PDT
Comment on attachment 534715 [details] [diff] [review]
move layout/xul/base/test/* from mochitest-plain -> chrome (2.0)

I honestly don't know.  Looks to me like it should be ok, but if you want to be sure check with the test authors?
Comment 6 Joel Maher ( :jmaher) 2011-05-24 08:38:51 PDT
ehsan, can to look at test_bug477754.xul and make sure that it would be ok as a mochitest-chrome test.

wladimir, cna you look at testUbug393970.xul and make sure that it would be ok as a mochitest-chrome test.

Neil, can you verify test_stack.xul is safe to move to mochitest-chrome.
Comment 7 Wladimir Palant 2011-05-24 12:53:45 PDT
Comment on attachment 534715 [details] [diff] [review]
move layout/xul/base/test/* from mochitest-plain -> chrome (2.0)

Changing test_bug393970.xul seems fine to me, this test was about chrome UI in the first place.
Comment 8 Joel Maher ( :jmaher) 2011-06-09 10:29:56 PDT
http://hg.mozilla.org/mozilla-central/rev/85394deb049d
Comment 9 :Ehsan Akhgari 2011-06-09 15:07:03 PDT
(In reply to comment #6)
> ehsan, can to look at test_bug477754.xul and make sure that it would be ok as a
> mochitest-chrome test.

Sorry for the delay here.  FWIW, yes, this is fine.

Note You need to log in before you can comment on or make changes to this bug.