Closed Bug 653204 Opened 10 years ago Closed 10 years ago

Undoing (CTRL-Z) deleting text from an input still validates as empty with attribute required

Categories

(Firefox :: General, defect)

4.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 318065

People

(Reporter: mike, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Deleting text from an input that has the attribute required, causes the input to validate as being empty and puts a red boarder around it, which is correct, but if you undo (ctrl-z) the text back into the input it still thinks it is empty, you have to change the text to something else then back to what you wanted for it to re-validate

Reproducible: Always

Steps to Reproduce:
1.Create an input element and add the required attribute
2.Type some text in and un-focus from the element
3.Delete the text from the element and un-focus, should cause it to turn red
4.Place cursor on the element and undo deleting it and then un-focus


Actual Results:  
Should still be red and show an error when trying to submit saying it is blank

Expected Results:  
Should of re-checked if the element is empty, or undoing typing should trigger a on-change
Version: unspecified → 4.0 Branch
Dupe of Bug 318065?
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318065
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.