TI: Assertion failure: obj, at ../jsval.h:711

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: decoder, Assigned: jandem)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
The following testcase asserts on TI revision 09cce9915b80 (run with -m -n -a),
tested on 64 bit:

function testSlowArrayPopMultiFrame() {    
    a = undefined;
    function parent(a, i) { i };
    function gramps(a, i) { 
        return parent;
    }
    var last;
    for (var i = 0; ; gramps++)
        last=gramps(a, i)
}(testSlowArrayPopMultiFrame(), 23)
(Assignee)

Comment 1

6 years ago
Created attachment 530175 [details] [diff] [review]
Patch
Assignee: general → jandemooij
Status: NEW → ASSIGNED
Attachment #530175 - Flags: review?(bhackett1024)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 653467
Attachment #530175 - Flags: review?(bhackett1024) → review+
(Assignee)

Comment 3

6 years ago
http://hg.mozilla.org/projects/jaegermonkey/rev/4f15ed48c44e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Blocks: 676763
(Reporter)

Comment 4

4 years ago
A testcase for this bug was automatically identified at js/src/jit-test/tests/jaeger/bug653397.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.