Spell check words stuck in right-click menu

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Lew Ayotte, Unassigned)

Tracking

4.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

I have no idea how this started and have no idea how to reproduce it yet. But all of a sudden the right-click menu always displays the same five words. Even if I right click on non-input fields. And if I right click on a misspelled word, it has the stuck five words and the recommended 5 words (10 total).

Reproducible: Didn't try




Here are some screenshots:
http://lewayotte.com/wp-content/uploads/2011/04/FF4-bug-1.png
http://lewayotte.com/wp-content/uploads/2011/04/FF4-bug-2.png
http://lewayotte.com/wp-content/uploads/2011/04/FF4-bug-3.png

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 4.0 Branch
(Reporter)

Comment 2

7 years ago
No, as soon as I restarted Firefox, the "stuck" spellcheck disappeared. It's probably one of those impossible to find bugs, but I will try to figure out what happened and how to reproduce.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 3

6 years ago
Hey there,

I'm having a similar issue. 

When I right click, I get a giant list of suggested words that I have to scroll down through until I can reach whatever action I want to perform (open in new tab, etc). The words seem to be variations/suggestions for typos I have made in the past. So for even just a single word, there can be 10 suggestions ... so if you make several typos, over time ... The suggested word list keeps getting longer and longer ... 

This happens with every right click -- not just when right clicking a misspelled word underlined in red.

Comment 4

5 years ago
I'm getting this bug too.  Again, I can't figure out reproducing it.  More and more stuff piling into the help list.

If it helps, the word "counter intuitive" set off its confusion this time.  Hyphen troubles?

Comment 5

5 years ago
Definitely present in 15.0.1
(Reporter)

Comment 6

5 years ago
Oddly enough, it just happened to me too... with the word "trustwave".

I also cannot right click and "open link in new tab" since the bug cropped up.

Comment 7

3 years ago
I have this issue too
You need to log in before you can comment on or make changes to this bug.