Content process hang or crash when scrolling overflow content

VERIFIED FIXED

Status

defect
--
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({crash, regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:  Open http://people.mozilla.com/~bstover/testcase.scrolling.html or a post in http://www.google.com/reader/i/ that overflows the viewport width.  Scroll the overflow content.

Results: The content process hangs (the page stops painting; loading new remote pages has no effect; tabs won't close).  Mark Finkle reports that the content process crashes in his build.

I can reproduce this 100% in a local trunk opt build on Galaxy Tab, but not in desktop Linux.  I cannot reproduce it in the 2011-04-29 nightly build.  Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ff152a406ed3&tochange=a008a3fda2b5

Bug 640048 is the most obviously related changeset in that range, but it could be something else.
I can verify that bug 640048 is the cause. I could 100% reproduce the crash on http://people.mozilla.com/~bstover/testcase.scrolling.html

With the patch backed out, I could not reproduce the crash at all. I backed out the patch:
http://hg.mozilla.org/mozilla-central/rev/44f2b2c318b0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified fixed on build: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110504
Firefox/6.0a1 Fennec/6.0a1 
Device: LG Optimus 2X
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.