Closed Bug 653910 Opened 9 years ago Closed 2 years ago

onItemAnnotationRemoved notified even if there were no annotations.

Categories

(Toolkit :: Places, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1417101

People

(Reporter: mak, Unassigned)

References

Details

This is useless notifications traffic, it should not notify a change if there was no change. Unfortunately checking existence before deletion could make things slower.

One of the problems here is that if a bookmark has 10 tags, on its removal we notify 11 onItemChanged just to say we did remove some not existing annotations.
Blocks: 468307
Priority: -- → P3
Fixed by bug 1417101.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417101
You need to log in before you can comment on or make changes to this bug.