FireFox kills Java-plugin when Applet startup takes more than ~20s

RESOLVED INVALID

Status

()

Core
Plug-ins
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Clemens Eisserer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When loading applets that need a lot of time to start up (in our case a lot of database initialization), firefox simply kills the Java-Plugin after about ~20s.

The whole out-of-process plugin is simply shut down (even a open java-console is closed), the area where the plugin should be is not painted.

Happens with both Java6 u22 and u25 (new Plugin2), on Linux as well as on Windows-XP with FireFox4. 
Additionally, on Linux during applet loading the browser is completly un-responsive.


Reproducible: Always

Steps to Reproduce:
1. load the html page mentioned above (also attached)
2. wait 10-20s for firefox to kill the java process
3.

Actual Results:  
firefox kills the plugin

Expected Results:  
after the applet has finished loading/initialization, it should show up as expected.
(Reporter)

Comment 1

7 years ago
Created attachment 529286 [details]
page containing the applet
(Reporter)

Comment 2

7 years ago
Created attachment 529287 [details]
Applet compiled
(Reporter)

Comment 3

7 years ago
Created attachment 529288 [details]
applet source code

Comment 4

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
URL works for me on XP
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 5

7 years ago
Yes, we do this intentionally, although it is 45 seconds, not 20. You should perform long-running tasks from the event loop or a secondary thread, not during initialization.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

7 years ago
On Linux with FireFox-4 its not more than 20s, my applet fails miserably.
(Reporter)

Comment 7

7 years ago
Created attachment 529307 [details]
screenshot of failed applet after ~15s.
(Reporter)

Comment 8

7 years ago
just stop-watched, after 20s the applet is terminated.

Well, does somebody have connections to Oracle. They should really adopt the plugin to not block the browser's event thread during initialization.
However as ordinary user reporting bugs ... is almost useless.
You need to log in before you can comment on or make changes to this bug.