visual auto resize problem in add-on manager with tree style tabs

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: pedbessa, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Since two blank spaces aren't a percentage width, I attached lookwhathappens.jpg. One's by the right of Add, Languages, Extensions. The other's by the right of the extension names.

wide screen - it's 1680, but I use 1440 to zoom
tree style tabs - on left, always visible
slim add-on manager - removes bloat
add-on compatibility reporter (by the way, Compatibility and arrow down only appears in add-on manager when I click an other category like Plugins, then go back to Extensions, by the way too, add-ons and plugins or add-ons and plug-ins or addons and plugins?)

Reproducible: Always

Steps to Reproduce:
1. install tree style tabs, add-on compatibility reporter, slim add-on manager
2. make the screen resolution be 1440 x 900
3. Tools -> Add-ons

Actual Results:  
add-on manager becames hard to navigate, having to go scroll right and left lots of times to read names and take actions

Expected Results:  
add-on manager becomes easy to navigate, having to scroll only up and down
(Reporter)

Comment 1

8 years ago
Created attachment 529300 [details]
two blank spaces, fixed width that should be percentage width
(Reporter)

Comment 2

8 years ago
Fonts are proportional 16 and monospaced 12.
(Reporter)

Comment 3

8 years ago
An alternative solution is to make the action buttons appear below the extension names.

Updated

8 years ago
Version: unspecified → 4.0 Branch

Updated

8 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: 4.0 Branch → 2.0 Branch
Sounds like a bug caused by tree style tabs. If you can reproduce this without tree style tabs open then please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.