Last Comment Bug 653959 - warning C4273: 'js_DeclEnvClass' : inconsistent dll linkage
: warning C4273: 'js_DeclEnvClass' : inconsistent dll linkage
Status: RESOLVED FIXED
[build_warning][fixed-in-tracemonkey]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks: 634590 671947
  Show dependency treegraph
 
Reported: 2011-04-30 17:52 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2011-07-15 13:24 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (751 bytes, patch)
2011-05-01 17:35 PDT, Ryan VanderMeulen [:RyanVM]
luke: review+
Details | Diff | Review

Description Ryan VanderMeulen [:RyanVM] 2011-04-30 17:52:07 PDT
dist\include\jsfun.h(299) : warning C4273: 'js_DeclEnvClass' : inconsistent dll linkage
        dist\include\jsobj.h(1695) : see previous definition of 'js_DeclEnvClass'

In jsfun.h, the define is:
extern js::Class js_DeclEnvClass;

In jsobj.h, it was declared in bug 634590 as:
extern JS_FRIEND_DATA(js::Class) js_DeclEnvClass;
Comment 1 Ryan VanderMeulen [:RyanVM] 2011-05-01 17:35:05 PDT
Created attachment 529398 [details] [diff] [review]
Fix
Comment 2 Ryan VanderMeulen [:RyanVM] 2011-05-02 18:07:39 PDT
Comment on attachment 529398 [details] [diff] [review]
Fix

Luke, Brendan's tied up right now. Can you review?
Comment 3 Ryan VanderMeulen [:RyanVM] 2011-05-04 16:22:55 PDT
I don't have commit access, so I'll need some help getting this checked into tm.
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-05-10 15:11:27 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/3a6b0d5e35be
Note: not marking as fixed because fixed-in-tracemonkey is not present on the whiteboard.

Note You need to log in before you can comment on or make changes to this bug.