Style Inspector rows should show visual indicator when there are unmatched rules but not matched rules

RESOLVED FIXED

Status

()

Firefox
Developer Tools
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: miker, Assigned: miker)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

In the Style Inspector it is currently possible to click:
1. A CSS Property: this displays the MDC page about that property
2. A properties value or anywhere else on the row: If there are unmatched rules then they will be expanded on the rows below, but otherwise nothing happens.

You currently have to click on each computed style in turn in order to discover which CSS values have unmatched rules. We need to add a visual indicator to simplify this.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
I was finally able to get a handle on this. The problem is that no visual indicator is displayed when there are unmatched rules but not matched rules.
Summary: Style Inspector rows should show visual indicator when unmatched rules exist → Style Inspector rows should show visual indicator when there are unmatched rules but not matched rules
Depends on: 582596
Created attachment 531323 [details] [diff] [review]
Add unmatched indicator
Created attachment 531339 [details] [diff] [review]
Add unmatched indicator 2

Improved patch
Attachment #531323 - Attachment is obsolete: true
Created attachment 531552 [details] [diff] [review]
Add unmatched indicator 3

Noticed a property that could potentially make the display of this link optional so the patch now uses it.
Attachment #531339 - Attachment is obsolete: true
This fix was added to the patch for bug 582596
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.