Last Comment Bug 654080 - Display which GLIBCXX symbols cause an error
: Display which GLIBCXX symbols cause an error
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 643690
  Show dependency treegraph
 
Reported: 2011-05-02 04:33 PDT by Mike Hommey [:glandium]
Modified: 2011-05-08 22:44 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Display which GLIBCXX symbols cause an error (1.96 KB, patch)
2011-05-02 04:33 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Review
Display which GLIBCXX symbols cause an error. (2.24 KB, patch)
2011-05-08 22:38 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Review

Description Mike Hommey [:glandium] 2011-05-02 04:33:49 PDT
Created attachment 529446 [details] [diff] [review]
Display which GLIBCXX symbols cause an error

In bug 643690, I added an error displaying GLIBCXX versions we don't want to link against. It would be more useful to also list which symbols correspond to these versions.

(Note that I used > /dev/null instead of grep -q because I don't know if we can rely on grep providing the -q option)
Comment 1 Mike Hommey [:glandium] 2011-05-06 00:59:00 PDT
While at it, "Error" in the message doesn't seem to trigger anything on tinderbox logs :-/
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1304659221.1304663419.6828.gz

Does it need to be on stderr or something?
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-06 01:11:46 PDT
http://mxr.mozilla.org/mozilla-central/search?string=tinderboxprint
Comment 3 Mike Hommey [:glandium] 2011-05-06 02:12:02 PDT
Does that mean we need TinderboxPrint *and* Error to be displayed on tbpl?
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-05-06 05:27:30 PDT
No. TinderboxPrint is what makes things show up in the build column on tinderbox.mozilla.org. The error parser controls what shows up in the summary of the short log:
http://mxr.mozilla.org/mozilla/source/webtools/tinderbox/ep_unittest.pl
Comment 5 Mike Hommey [:glandium] 2011-05-06 05:31:23 PDT
So, we need to abuse one of these:
http://mxr.mozilla.org/mozilla/source/webtools/tinderbox/ep_unittest.pl#27

Or should we add a generic type of error there ?
Comment 6 Ted Mielczarek [:ted.mielczarek] 2011-05-06 05:35:25 PDT
I'd just print TEST-UNEXPECTED-FAIL, honestly, since this is in "make check". I think we don't match "Error:" because we get too many false positives from tests that have expected JS Errors or print that string in the test text, etc.
Comment 7 Mike Hommey [:glandium] 2011-05-06 05:40:03 PDT
fair enough, though it's not in make check, but in plain make.
Comment 8 Ted Mielczarek [:ted.mielczarek] 2011-05-06 06:24:49 PDT
Comment on attachment 529446 [details] [diff] [review]
Display which GLIBCXX symbols cause an error

Review of attachment 529446 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the output fixed to match the tinderbox error parser.
Comment 9 Mike Hommey [:glandium] 2011-05-08 22:38:19 PDT
Created attachment 530985 [details] [diff] [review]
Display which GLIBCXX symbols cause an error.
Comment 10 Mike Hommey [:glandium] 2011-05-08 22:44:23 PDT
http://hg.mozilla.org/mozilla-central/rev/d21dae3474b3

(the new attachment was the patch as landed)

Note You need to log in before you can comment on or make changes to this bug.