Last Comment Bug 654082 - Building in gcc c++0x mode uses symbols from libstdc++ 4.5 on debug builds
: Building in gcc c++0x mode uses symbols from libstdc++ 4.5 on debug builds
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 650304
  Show dependency treegraph
 
Reported: 2011-05-02 05:03 PDT by Mike Hommey [:glandium]
Modified: 2011-06-12 02:38 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add C++0x support to the libstdc++ compatibility hack (1.70 KB, patch)
2011-05-02 05:03 PDT, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-05-02 05:03:43 PDT
Created attachment 529451 [details] [diff] [review]
Add C++0x support to the libstdc++ compatibility hack

This is because it switches to using some new C++0x defined methods in std::string and std::wstring.

(At the same time, replace basic_string template with shorter string and wstring form, and add an ifdef for wchar_t ; i verified this doesn't break in non C++0x mode)
Comment 1 (dormant account) 2011-05-02 09:36:46 PDT
Comment on attachment 529451 [details] [diff] [review]
Add C++0x support to the libstdc++ compatibility hack

rubberstamp
Comment 2 Mike Hommey [:glandium] 2011-05-03 01:38:44 PDT
http://hg.mozilla.org/mozilla-central/rev/316b764ae6c0

Note You need to log in before you can comment on or make changes to this bug.