Status

Firefox Build System
General
RESOLVED FIXED
7 years ago
2 months ago

People

(Reporter: Bengt-Erik Soderstrom, Assigned: glandium)

Tracking

unspecified
mozilla21
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110501 Firefox/6.0a1 SeaMonkey/2.2a1pre
Build Identifier: Nightly 6.0a1  2011-05-02  

Trying to build with elfhack rresults in this:

== If you get failures below, please file a bug describing the error
=== and your environment (compiler and linker versions), and use
=== --disable-elf-hack until this is fixed.
===
cd ../../dist/bin; find . -name "*.so" | xargs ../../build/unix/elfhack/elfhack
elfhack: /home/bengt-erik/mozilla-central/src/build/unix/elfhack/elf.cpp:286: Elf::Elf(std::ifstream&): Assertion `segment->getMemSize() == phdr.p_memsz' failed.
xargs: ../../build/unix/elfhack/elfhack: avslutades av signal 6 (terminated by signal 6)
make[2]: *** [elfhack] Fel 125 (Error  125)

Building as such is OK, this happens when using 'make package'

Compiler: gcc 4.5.2  (Ubuntu 11.04)
Linker  : GNU gold (GNU Binutils 2.21.51.20110227) 1.11

when using --disable-elf-hack everything is OK


Reproducible: Always
Component: General → Build Config
QA Contact: general → build-config
(Assignee)

Updated

7 years ago
Assignee: nobody → mh+mozilla

Comment 1

7 years ago
I have same problem compiling Firefox 7.0.1 with PGO.
I don't understand that if it disables the elfhack when I configure/compile, why it fails when I try to install it with "sudo make -f client.mk install" because this?

Comment 2

7 years ago
Same problem here compiling FF 7.0.1 with PGO
Tried the --disable-elf-hack, but this elf-hack makes icc to lose its compatibility to compile as what ./configure said
I am seeing this same bug when compiling with PGO.  The problem looks like that we have a .tbss section of 16x + 8 bytes and the TLS segment that contains it has a memsz of 16(x+1) bytes.  Both section and segment are said to be 16-byte aligned.  Will upload an example file in a second.
Created attachment 566619 [details]
failing library

An x86-64 shared library that exhibits the problem.  Compiled with close-to-tip GCC 4.7 and linked with trunk gold.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
this affects me as well, not sure what other information is needed.
(Assignee)

Comment 6

6 years ago
(In reply to Joel Maher (:jmaher) from comment #5)
> this affects me as well, not sure what other information is needed.

If your problem is http://pastebin.mozilla.org/1412669 that would be a separate issue. Please file a new bug with that log, as well as a copy of the file on which elfhack segfaults (apparently, libplugin-container.so)
(Assignee)

Comment 7

5 years ago
Created attachment 702271 [details] [diff] [review]
Don't error out on gold special treatment of PT_TLS segment memsize
Attachment #702271 - Flags: review?(nfroyd)
Attachment #702271 - Flags: review?(nfroyd) → review+
(Assignee)

Updated

5 years ago
Duplicate of this bug: 829818
https://hg.mozilla.org/mozilla-central/rev/eb1363fb8a2d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.