Firefox crashes when running VACUUM on a database using SQLite Manager addon [@ sqlite3DbMallocRaw ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: mrinal.kant, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

The problem occurs with firefox 4.0, 4.0.1, aurora and nightly but not on Seamonkey 2.1b3pre even when using the same version of addon.

Reproducible: Always

Steps to Reproduce:
1. Install SQLite Manager version 0.7.1
2. Try to "Compact Database" from "Database" menu or by running "VACUUM" under the Execute SQL tab

Actual Results:  
Firefox crashes.

Expected Results:  
Database should be compacted. Firefox should not crash.
0 	libmozsqlite3.so 	sqlite3DbMallocRaw 	sqlite3.c:18075
1 	libmozsqlite3.so 	sqlite3VdbeMemGrow 	sqlite3.c:54091
2 	libmozsqlite3.so 	sqlite3VdbeMemNulTerminate 	sqlite3.c:54179
3 	libmozsqlite3.so 	sqlite3VdbeExec 	sqlite3.c:61387
4 	libmozsqlite3.so 	sqlite3_step 	sqlite3.c:58704
5 	libmozsqlite3.so 	execSql 	sqlite3.c:94121
6 	libmozsqlite3.so 	execExecSql 	sqlite3.c:94138
7 	libmozsqlite3.so 	sqlite3VdbeExec 	sqlite3.c:94302
8 	libmozsqlite3.so 	sqlite3_step 	sqlite3.c:58704
9 	libxul.so 	mozilla::storage::stepStmt 	storage/src/mozStoragePrivateHelpers.cpp:283
10 	libxul.so 	mozilla::storage::Statement::ExecuteStep 	storage/src/mozStorageStatement.cpp:617
11 	libxul.so 	libxul.so@0xd3dabe 	
12 	libxul.so 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3124
13 	libxul.so 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1613
Assignee: Jan.Varga → nobody
Component: SQL → Storage
Keywords: crash
Product: Core → Toolkit
QA Contact: omarshall → storage
Summary: Firefox crashes when running VACUUM on a database using SQLite Manager addon → Firefox crashes when running VACUUM on a database using SQLite Manager addon [@ sqlite3DbMallocRaw ]
Version: unspecified → 2.0 Branch
(Reporter)

Comment 4

7 years ago
running VACUUM on a database using the xulrunner app version (using xulrunner-2.0) of the same extension on Ubuntu 11.04 works fine.
Component: Storage → SQL
Product: Toolkit → Core
SQL::Core is dead.  You never ever actually want to use it.
Component: SQL → Storage
Product: Core → Toolkit
Is it possible for you to e-mail me the database please?
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> Is it possible for you to e-mail me the database please?

Yes, of course. I have already mailed it to you.
(In reply to comment #7)
> Yes, of course. I have already mailed it to you.
I've received this, but have not had a chance to look it over yet.
(Assignee)

Updated

7 years ago
Crash Signature: [@ sqlite3DbMallocRaw ]
(Reporter)

Comment 9

7 years ago
(In reply to Shawn Wilsher :sdwilsh (Vacation Dec 17 - Jan 5) from comment #8)
> (In reply to comment #7)
> > Yes, of course. I have already mailed it to you.
> I've received this, but have not had a chance to look it over yet.

I think we can close this bug. The problem was occuring whenever the pragma count_changes = 1; was set. running vacuum after pragma count_changes = 0; does not lead to crash.

I got the clue from the following comment at http://www.sqlite.org/releaselog/3_7_9.html :
"Fix a bug that caused VACUUM to fail if the count_changes pragma was engaged."
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.