Persona doesn't load if no internet connection is active on program launch and does not reload once connection is restored

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: lukekann, Unassigned)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Personas do not load when no internet connection is active when Firefox is launched. Firefox just displays a grey base skin. When the connection is restored (proxy settings entered etc.) the persona does not load. Also when international bandwidth is unavailable, the persona will also not load. Why should a persona need an active international internet connection to load? The persona should load everytime, irrespective of whether a connection is available at launch or not.

Reproducible: Always

Steps to Reproduce:
1. Disable internet connection/use firefox behind a proxy without proxy details entered
2. Launch firefox with a persona enabled


Actual Results:  
No persona loads, plain grey skin

Expected Results:  
Loaded my active persona, or at least loaded the persona when the connection was restored.

Comment 1

8 years ago
Works for me with Windows XP SP3.
Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Are you able to reproduce the bug with a new, clean profile?
https://support.mozilla.com/en-US/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Version: unspecified → 4.0 Branch

Comment 2

7 years ago
WFM:
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120228 Firefox/13.0a1

No response from the reporter. Feel free to reopen the bug if more information is available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.