Last Comment Bug 654371 - nsOggReader.cpp:1065:18: warning: unused variable ‘range’
: nsOggReader.cpp:1065:18: warning: unused variable ‘range’
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 650994
Blocks: 639391
  Show dependency treegraph
 
Reported: 2011-05-02 22:58 PDT by Daniel Holbert [:dholbert] (largely AFK until June 28)
Modified: 2011-05-08 00:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Holbert [:dholbert] (largely AFK until June 28) 2011-05-02 22:58:45 PDT
Filing bug on this build warning:

> nsOggReader.cpp: In member function ‘nsresult nsOggReader::GetSeekRanges(nsTArray<nsOggReader::SeekRange>&)’:
> nsOggReader.cpp:1065:18: warning: unused variable ‘range’

This variable is just an alias for cached[index], but it looks like we never used the alias even in the cset that added it:
  http://hg.mozilla.org/mozilla-central/rev/d3aeb102da2b

cpearce, perhaps you intended to replace the "cached[index]" usages with the alias?  Or, should this variable just go away?
Comment 1 Daniel Holbert [:dholbert] (largely AFK until June 28) 2011-05-02 22:59:50 PDT
Here's the link to the flagged line in MXR, for reference:
http://mxr.mozilla.org/mozilla-central/source/content/media/ogg/nsOggReader.cpp#1065
Comment 2 Chris Pearce (:cpearce) 2011-05-03 02:54:54 PDT
Thanks, I've got a fix for this included in my patch in bug 650994.
Comment 3 Chris Pearce (:cpearce) 2011-05-08 00:56:34 PDT
Fixed by landing of bug 650994.

Note You need to log in before you can comment on or make changes to this bug.