RFE: Spellchecker ReplaceAll needs case insensitive matching

RESOLVED INVALID

Status

()

Core
Editor
P3
normal
RESOLVED INVALID
19 years ago
14 years ago

People

(Reporter: kinmoz, Assigned: kinmoz)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
The spellchecker only replaces words that match in both spelling and case. It
should do case insensitive matching. For example, if I wanted to replace all
occurrences of "ths" with "this", all occurrences of "Ths" will be ignored and
not replaced.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7
(Assignee)

Updated

19 years ago
Target Milestone: M7 → M8
(Assignee)

Comment 1

19 years ago
Changed milestone to M8, when I will revisit TextServices and Spellchecker
issues.
(Assignee)

Comment 2

19 years ago
Changing milestone to M9 since I don't have time to look at spellchecker
issues yet.

Comment 3

19 years ago
I don't think it should do this--at least not by default.  4.x does not have that
functionality.
(Assignee)

Comment 4

19 years ago
Moving all spellchecker/text services related bugs to M11 since I will still be
working on AutoComplete features through M10.
(Assignee)

Comment 5

19 years ago
Moving some SpellChecker/TextServices feature requests and bugs, that can wait
till after beta 1, to milestone M14.

Comment 6

18 years ago
m15
Target Milestone: M14 → M15
(Assignee)

Comment 7

18 years ago
Moving all non-beta1 bugs to M16 since I am going on sabbatical.
Target Milestone: M15 → M16
(Assignee)

Comment 8

18 years ago
Move to M20. Also need to add option/checkbox on dialog.
Summary: Spellchecker ReplaceAll needs case insensitive matching → RFE: Spellchecker ReplaceAll needs case insensitive matching
Target Milestone: M16 → M20

Comment 9

18 years ago
moving to future milestone
Assignee: kin → beppe
Status: ASSIGNED → NEW

Updated

18 years ago
Target Milestone: M20 → Future

Comment 10

18 years ago
moving back to previous owner
Assignee: beppe → kin
(Assignee)

Comment 11

18 years ago
Accepting bug.
Status: NEW → ASSIGNED

Comment 12

18 years ago
adding help wanted keyword
Keywords: helpwanted
There's not much point in this being Help Wanted - unless you want to open 
source the spell checker :-)

Gerv

Updated

16 years ago
Blocks: 119232

Comment 14

14 years ago
Sorry, I'm going to call this one invalid.

I checked Lotus Notes, Lotus WordPro, and even Microsoft Word.

Noone does this.

This is not expected behavior.

Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 15

14 years ago
In the interest of truth and accuracy, MS Word's ReplaceAll is, by default, case
insensitive and offers a "Match case" switch in the expanding dialogue accessed
by the "More" button.
You need to log in before you can comment on or make changes to this bug.