Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 65473 - list bullets and other text overlap floats
: list bullets and other text overlap floats
Status: VERIFIED DUPLICATE of bug 57882
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.2alpha
Assigned To: Marc Attinasi
: Chris Petersen
: Jet Villegas (:jet)
: 111109 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2001-01-14 20:16 PST by Chris Abbey
Modified: 2002-03-19 04:59 PST (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

a sample test case from the page (745 bytes, text/html)
2001-03-19 18:33 PST, Chris Petersen
no flags Details
More optimized testcase (245 bytes, text/html)
2001-08-16 07:28 PDT, Håkan Waara
no flags Details
original case - now seems fixed (1.93 KB, text/html)
2001-08-16 19:45 PDT, Chris Abbey
no flags Details

Description Chris Abbey 2001-01-14 20:16:49 PST
When the page is first painted the lower text is rendered across the whole
browser width, then the lower right image is rendered under the text. A resize
of the window will correct the layout, as will a cached reload. Shift-reload
will repaint incorrectly.

I suspect the problem is that the images contain height tags, but no width tag
and are initially placed with a width of 0, once they load however they pop out
to their normal width but the rest of the view is not adjusted. Perhaps when the
image width is corrected an invalidate needs to happen to the rest of the layout?

while this isn't the cleanest HTML in the world I think it can be handled
better; if they complain about the reflow flash then tell them to clean up their
html and it wouldn't happen.
Comment 1 Chris Abbey 2001-01-14 20:17:41 PST
bah, forgot to mention that the build id is 2001011408.
Comment 2 Keyser Sose 2001-01-16 20:13:16 PST
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001011608

Marking NEW.
Comment 3 Keyser Sose 2001-01-17 18:14:04 PST
Really Marking NEW.
Comment 4 Chris Petersen 2001-03-19 18:33:19 PST
Created attachment 28197 [details]
a sample test case from the page
Comment 5 Chris Petersen 2001-03-19 18:36:02 PST
I gave the image a width value of 200 pixels but doen't seem to resolve the 
Comment 6 karnaze (gone) 2001-03-30 15:36:37 PST
Reassigning to attinasi and moving to m1.0.
Comment 7 Chris Abbey 2001-05-02 23:41:10 PDT
cleared url, as the page has been completely redesigned. Also kicking my self
for not capturing a copy.  (old url: )
Comment 8 Marc Attinasi 2001-05-03 10:39:46 PDT
Fortunately the testcase attached shows the problem (assuming that the list
items over the image was the problem!)
Comment 9 Chris Abbey 2001-05-15 11:43:01 PDT
while that is a valid problem, and is similar, it isn't the one I originally
meant. I'll see if I can coble together a second test case. The key information
should be that the images only have one dimension given in the html, and thus
their rendering changes when they finish loading.

I suspect that in a newer (libpr0n equiped) build it would assert because of the
zero width. (enough other stuff does)
Comment 10 Håkan Waara 2001-08-16 07:28:37 PDT
Created attachment 46063 [details]
More optimized testcase
Comment 11 David Baron :dbaron: ⌚️UTC-7 2001-08-16 07:31:35 PDT
Seems like bug 802 has regressed.  We should really figure out what CSS3 will
say about intrusions and list bullets, and implement that...

Ian:  Is there another bug on this?
Comment 12 Hixie (not reading bugmail) 2001-08-16 13:33:05 PDT
There is a bug on the initial floating image size not being updated when the
image comes in, and there are bugs on -moz-float-edge sucking, but I don't know
if this is either of those bugs.
Comment 13 Chris Abbey 2001-08-16 18:16:03 PDT
Ian, the problem I was originally reporting is the first of those two, the
problems demonstrated in the attachments todate are the second.
Comment 14 Chris Abbey 2001-08-16 19:45:13 PDT
Created attachment 46176 [details]
original case - now seems fixed
Comment 15 Chris Abbey 2001-08-16 19:50:10 PDT
The test case I've just attached is a recreation of the problem I was originally
reporting. It does not however fail with a modern build. If y'all want to keep
the bug open for the list item problem you've been discussing that's fine by me,
but the original problem has been resolved for a while.
Comment 16 Christian Reis 2001-09-03 22:10:09 PDT
Can we add bullets to the summary or is this bug more general?
Comment 17 Chris Abbey 2001-09-23 01:21:13 PDT
The URL I've just posted is a *current* example of the original problem I opened
this bug for - look at the two inline pictures and the text below them.
Screenshot and a static copy of the page in question are on ... I'll see about trimming this down from there,
but it looks like it's a floating table containing an image without any
dimensions in the html. These were taken from a build on a fresh extract this
Comment 18 David Baron :dbaron: ⌚️UTC-7 2001-11-27 14:44:13 PST
*** Bug 111109 has been marked as a duplicate of this bug. ***
Comment 19 Boris Zbarsky [:bz] (still a bit busy) 2002-01-04 21:17:44 PST
How is this different from bug 57882?
Comment 20 David Baron :dbaron: ⌚️UTC-7 2002-01-05 06:57:13 PST

*** This bug has been marked as a duplicate of 57882 ***
Comment 21 Hixie (not reading bugmail) 2002-03-19 04:59:52 PST

Note You need to log in before you can comment on or make changes to this bug.