Last Comment Bug 654891 - warning C4509: nonstandard extension used: 'PluginWindowEvent::Run' uses SEH and 'inst' has destructor
: warning C4509: nonstandard extension used: 'PluginWindowEvent::Run' uses SEH ...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla9
Assigned To: Jim Mathies [:jimm]
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2011-05-04 16:56 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2011-09-18 12:26 PDT (History)
2 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.08 KB, patch)
2011-05-20 12:45 PDT, Jim Mathies [:jimm]
benjamin: review+
Details | Diff | Splinter Review

Description Ryan VanderMeulen [:RyanVM] 2011-05-04 16:56:49 PDT
MSVC 2010 SP1 complains about this. Looks possibly troublesome.

c:/mozbuild/mozilla-central/dom/plugins/base/nsPluginNativeWindowWin.cpp(592) : warning C4509: nonstandard extension used: 'PluginWindowEvent::Run' uses SEH and 'inst' has destructor
	c:/mozbuild/mozilla-central/dom/plugins/base/nsPluginNativeWindowWin.cpp(592) : see declaration of 'inst'
Comment 1 Jim Mathies [:jimm] 2011-05-20 12:45:07 PDT
Created attachment 534071 [details] [diff] [review]
patch

Thought we dropped all the exception handling in the old plugin code. I guess there's still some of it left hanging around.
Comment 2 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-05-23 05:46:47 PDT
Comment on attachment 534071 [details] [diff] [review]
patch

the try-safe stuff is preffed off by default now but not removed, it's on my list of things to do
Comment 3 Ed Morley [:emorley] 2011-08-26 17:56:19 PDT
I presume this makes the |NS_ENSURE_TRUE(aInst, NS_ERROR_NULL_POINTER)|, here: http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/nsPluginNativeWindowWin.cpp#182
...redundant?

Other than that, happy for me to land this? (Attempting to work my way through the build warnings meta dependants, starting with those with patches).

In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> the try-safe stuff is preffed off by default now but not removed, it's on my
> list of things to do

Happy for me to file a bug on removing it?
Comment 4 Jim Mathies [:jimm] 2011-09-07 07:38:22 PDT
(In reply to Ed Morley [:edmorley] from comment #3)
> I presume this makes the |NS_ENSURE_TRUE(aInst, NS_ERROR_NULL_POINTER)|,
> here:
> http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/
> nsPluginNativeWindowWin.cpp#182
> ...redundant?

I don't see how these changes insure GetPluginInstance can't return null.

> Other than that, happy for me to land this? 

sure.
Comment 5 Ed Morley [:emorley] 2011-09-17 05:51:22 PDT
(In reply to Jim Mathies [:jimm] from comment #4)
> (In reply to Ed Morley [:edmorley] from comment #3)
> > I presume this makes the |NS_ENSURE_TRUE(aInst, NS_ERROR_NULL_POINTER)|,
> > here:
> > http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/
> > nsPluginNativeWindowWin.cpp#182
> > ...redundant?
> 
> I don't see how these changes insure GetPluginInstance can't return null.

Only because aInst didn't appear to be used post patch, but I'm probably reading it wrong.
Comment 7 Ed Morley [:emorley] 2011-09-18 12:26:45 PDT
https://hg.mozilla.org/mozilla-central/rev/fbc0c5c938a9

Note You need to log in before you can comment on or make changes to this bug.