Remove !tsk.tr rule from PSL (reverse bug 606922)

RESOLVED FIXED

Status

()

Core
Networking: Domain Lists
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Ilhan Y., Assigned: gerv)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(status2.0 .x-fixed, status1.9.2 .18-fixed, status1.9.1 .20-fixed)

Details

(Whiteboard: [qa-examined-192], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

Firefox 6 highlights tsk.tr It should be hvkk.tsk.tr
There are 35 domainnames according to https://www.nic.tr/index.php?USRACTN=YEARSTAT#tsk.tr That means that hvkk is not a subdomain of the web site tsk.tr but it is another domainname registered at nic.tr

Thus, basicaly tsk.tr and hvkk.tsk.tr are seperate domainnames.

Reproducible: Always

Steps to Reproduce:
1. Install latest nightly http://nightly.mozilla.org/
2. See here that there are 35 domainnames with tsk.tr https://www.nic.tr/index.php?USRACTN=YEARSTAT#tsk.tr Like co.uk
3. Visit the http://www.hvkk.tsk.tr/EN/Index.aspx

Actual Results:  
Firefox shows that the domain name is tsk.tr, but it is false, it same as saying that co.uk is domainname.

Expected Results:  
Firefox should show that the domain name is hvkk.tsk.tr

Basicaly, hvkk.tsk.tr and sgk.tsk.tr are seperate domainnames.
(Reporter)

Updated

6 years ago
Summary: Firefox 6 highlights tsk.tr It should be hvkk.tsk.tr → Firefox 6 highlights tsk.tr instead of hvkk.tsk.tr at http://www.hvkk.tsk.tr/EN/Index.aspx
(Reporter)

Updated

6 years ago
OS: Windows 7 → All
Hardware: x86 → All
(Reporter)

Comment 1

6 years ago
Note: you need to visit with www (http://www.sgk.tsk.tr/ )
(Reporter)

Updated

6 years ago
Component: Networking: HTTP → Networking: Domain Lists

Comment 2

6 years ago
(In reply to comment #0)
> There are 35 domainnames according to
> https://www.nic.tr/index.php?USRACTN=YEARSTAT#tsk.tr That means that hvkk is
> not a subdomain of the web site tsk.tr but it is another domainname registered
> at nic.tr

The problem is that www.tsk.tr is both a real website, and a TLD.

Comment 3

6 years ago
I mean tsk.tr ofcourse.
(Reporter)

Comment 4

6 years ago
It seems that tsk.tr is not a domain. It seems that the domain is www.tsk.tr (with www part) Like www.co.uk where www is the registered one.

http://www.whois.com.tr/?q=www.tsk.tr
Also http://web-sniffer.net/ did not returned any information for tsk.tr (I mean no redirection)

Can someone recheck the whois of tsk.tr and then www.tsk.tr ?

Shortly, it seems that www is not a subdomain.

Updated

6 years ago
Component: Networking: Domain Lists → General
Product: Core → Firefox
QA Contact: networking.http → general

Updated

6 years ago
Component: General → Networking: Domain Lists
Product: Firefox → Core
QA Contact: general → networking.domain-lists
Assignee: nobody → gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

6 years ago
Hi again,

I think the erroneous behavior was on my side. I filed the previous request 606922 thinking that tsk.tr is a domain name. I actually confirmed this also by contacting Nic.tr. However, now it seems that, tsk.tr is only a TLD and WWW.tsk.tr is actually a domain name (OMG!!)

It can be checked at this address: 

I will also update the related wikipedia entry (if not already done).

Best,
Volkan

Comment 6

6 years ago
Sorry the address to check is: https://www.nic.tr/index.php?lang=TR_LANG
Blocks: 606922
(Assignee)

Comment 7

6 years ago
OK, so we need to back that !tsk.tr rule out.
Gerv
Summary: Firefox 6 highlights tsk.tr instead of hvkk.tsk.tr at http://www.hvkk.tsk.tr/EN/Index.aspx → Remove !tsk.tr rule from PSL (reverse bug 606922)
(Assignee)

Comment 8

6 years ago
Jothan: a great opportunity to hone your patch-making skills ;-)

Gerv
Assignee: gerv → jothan

Comment 9

6 years ago
Created attachment 534527 [details] [diff] [review]
pulls entry for !tsk.tr

This is the patch to remove !tsk.tr

Comment 10

6 years ago
OK, Patch attached, now assigning back to GM
Assignee: jothan → gerv
Status: NEW → ASSIGNED
(Assignee)

Comment 11

6 years ago
http://hg.mozilla.org/mozilla-central/rev/863a55927694

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #534527 - Flags: approval2.0?
Attachment #534527 - Flags: approval1.9.2.18?
Attachment #534527 - Flags: approval1.9.1.20?
Comment on attachment 534527 [details] [diff] [review]
pulls entry for !tsk.tr

Approved for 1.9.2.18 and 1.9.1.20, a=dveditz for release-drivers
Approved for the mozilla2.0 repository, a=dveditz for release-drivers
Attachment #534527 - Flags: approval2.0?
Attachment #534527 - Flags: approval2.0+
Attachment #534527 - Flags: approval1.9.2.18?
Attachment #534527 - Flags: approval1.9.2.18+
Attachment #534527 - Flags: approval1.9.1.20?
Attachment #534527 - Flags: approval1.9.1.20+
(Assignee)

Comment 13

6 years ago
http://hg.mozilla.org/releases/mozilla-2.0/rev/cb3e9d35d3be
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/30fc8b5a9a02
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/7a9bd385fa1b

Gerv
status1.9.1: --- → .20-fixed
status1.9.2: --- → .18-fixed
status2.0: --- → .x-fixed
What difference in behavior am I supposed to see here, post-checkin?
Whiteboard: [qa-examined-192]
(Assignee)

Comment 15

6 years ago
Al: visit http://www.hvkk.tsk.tr/TR/Index.aspx in Firefox 6. Before change, "tsk.tr" should be highlighted in the URL bar. After change, "hvkk.tsk.tr" should be highlighted.

Gerv
I'm looking at this in 3.6.18. :-) I'm doing branch verifications.
Al: for 3.6, you could compare the output of running:

Components.classes["@mozilla.org/network/effective-tld-service;1"].getService(Components.interfaces.nsIEffectiveTLDService).getBaseDomainFromHost("www.hvkk.tsk.tr")

in the error console (shows up under "Messages").
You need to log in before you can comment on or make changes to this bug.