Last Comment Bug 654975 - PGO breaks Linux crash reports
: PGO breaks Linux crash reports
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla6
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 654595
  Show dependency treegraph
 
Reported: 2011-05-05 05:00 PDT by Mike Hommey [:glandium]
Modified: 2011-05-05 12:27 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove -freorder-blocks-and-partition from PGO build options (2.51 KB, patch)
2011-05-05 05:00 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Remove -freorder-blocks-and-partition from PGO build options (3.22 KB, patch)
2011-05-05 05:13 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Remove -freorder-blocks-and-partition from PGO build options (3.87 KB, patch)
2011-05-05 09:45 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Remove -freorder-blocks-and-partition from PGO build options (3.98 KB, patch)
2011-05-05 10:29 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-05-05 05:00:21 PDT
Created attachment 530275 [details] [diff] [review]
Remove -freorder-blocks-and-partition from PGO build options

I isolated the lack of DW_AT_low_pc and DW_AT_high_pc from bug 654595 as a gcc 4.5 bug with -freorder-blocks-and-partition (4.4 is also affected, for that matter). gcc 4.6 apparently doesn't have this problem.

The problem is simply reproducible with this simple source code:
  int foo() { return 0; }

Compiled with gcc -o foo.o -c foo.c -g -freorder-blocks-and-partition

I still think we should fix bug 654595 on the dump_syms end, thus filing this separated bug to use as a workaround until we fix bug 654595.
Comment 1 Mike Hommey [:glandium] 2011-05-05 05:13:21 PDT
Created attachment 530277 [details] [diff] [review]
Remove -freorder-blocks-and-partition from PGO build options

We also need nsprpub/configure to be updated, obviously.
Comment 2 Mike Hommey [:glandium] 2011-05-05 09:45:55 PDT
Created attachment 530348 [details] [diff] [review]
Remove -freorder-blocks-and-partition from PGO build options

New version doing the very same, but without touching nsprpub/
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-05-05 09:58:47 PDT
Comment on attachment 530348 [details] [diff] [review]
Remove -freorder-blocks-and-partition from PGO build options

Review of attachment 530348 [details] [diff] [review]:

::: config/nspr/Makefile.in
@@ +58,5 @@
 # Copy NSPR to the SDK
 ABS_DIST = $(call core_abspath,$(DIST))
 
 libs::
+	$(MAKE) -C $(DEPTH)/nsprpub PROFILE_USE_CFLAGS="$(PROFILE_USE_CFLAGS)"

We can revert this bit after we land NSPR changes, right? Can you file another bug on the NSPR changes, and mention it in a comment here?
Comment 4 Mike Hommey [:glandium] 2011-05-05 10:10:33 PDT
(In reply to comment #3)
> Comment on attachment 530348 [details] [diff] [review] [review]
> Remove -freorder-blocks-and-partition from PGO build options
> 
> Review of attachment 530348 [details] [diff] [review] [review]:
> 
> ::: config/nspr/Makefile.in
> @@ +58,5 @@
>  # Copy NSPR to the SDK
>  ABS_DIST = $(call core_abspath,$(DIST))
> 
>  libs::
> +    $(MAKE) -C $(DEPTH)/nsprpub PROFILE_USE_CFLAGS="$(PROFILE_USE_CFLAGS)"
> 
> We can revert this bit after we land NSPR changes, right? Can you file another
> bug on the NSPR changes, and mention it in a comment here?

Filed bug 655058. By "here" you mean here, or in the patch? (we can revert all config/nspr/* changes when the nspr change lands)
Comment 5 Ted Mielczarek [:ted.mielczarek] 2011-05-05 10:12:51 PDT
In a comment in that bit of the patch, I mean.
Comment 6 Mike Hommey [:glandium] 2011-05-05 10:29:34 PDT
Created attachment 530363 [details] [diff] [review]
Remove -freorder-blocks-and-partition from PGO build options
Comment 7 Mike Hommey [:glandium] 2011-05-05 12:27:40 PDT
http://hg.mozilla.org/mozilla-central/rev/afcca618a5a4

Note You need to log in before you can comment on or make changes to this bug.