Closed Bug 654995 Opened 11 years ago Closed 11 years ago

Update buildbot for comm-miramar and set up an auto push for miramar repos

Categories

(Mozilla Messaging :: Release Engineering, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: gozer)

References

Details

Attachments

(1 file, 1 obsolete file)

Please set up an auto-push builder to push as follows (triggered by comm-central or comm-aurora pushes):

- comm-central -> releases/comm-miramar
- mozilla-aurora -> releases/mozilla-miramar

The comm-central part should need to be disabled on the 10th.

Please also set up buildbot to have a comm-miramar branch (replacing the existing comm-aurora builders) to build:

- releases/comm-miramar
- releases/mozilla-miramar
- releases/l10n-aurora

(note the different name for the l10n repos).
(In reply to comment #0)
> Please also set up buildbot to have a comm-miramar branch (replacing the
> existing comm-aurora builders) to build:
> 
> - releases/comm-miramar
> - releases/mozilla-miramar
> - releases/l10n-aurora
> 
> (note the different name for the l10n repos).

Correction, the repos are:

- releases/comm-miramar
- releases/mozilla-miramar
- releases/l10n/mozilla-aurora
Right now, safe to try in prod, it only runs hg outgoing instead of hg push, so you can see what it would push.
Attachment #530418 - Flags: review?(jhopkins)
Comment on attachment 530418 [details] [diff] [review]
[checked-in] mirror repos via buildbot

I applied this locally on buildbot, and did some changes. Can someone check the result in please?
Attachment #530418 - Flags: review?(jhopkins)
(In reply to comment #3)
> I applied this locally on buildbot, and did some changes. Can someone check
> the result in please?

Done.
Attachment #530418 - Attachment description: mirror repos via buildbot → [checked-in] mirror repos via buildbot
Attachment #530418 - Attachment is obsolete: true
Attachment #530652 - Flags: review?(jhopkins)
Comment on attachment 530652 [details] [diff] [review]
buildbot update for comm-miramar

Review of attachment 530652 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #530652 - Flags: review?(jhopkins) → review+
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.