crash [@ mozilla::storage::StorageMemoryReporter::GetPath] when viewing about:memory

RESOLVED DUPLICATE of bug 654573

Status

()

Toolkit
Storage
--
critical
RESOLVED DUPLICATE of bug 654573
7 years ago
7 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

({crash, regression})

Trunk
All
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
I got this crash on a session which I was running for about a day or so when I typed about:memory into the address bar.

This bug was filed from the Socorro interface and is 
report bp-f41965f0-3dae-4604-98b3-0f4332110505 .
=============================================================
(Reporter)

Updated

7 years ago
Component: General → Storage
Product: Firefox → Toolkit
QA Contact: general → storage
Version: unspecified → Trunk
All the changes made to storage/ by bug 633653 are shown in these two links:

http://hg.mozilla.org/mozilla-central/diff/1f0635e935d9/storage/src/mozStorageConnection.cpp
http://hg.mozilla.org/mozilla-central/diff/1f0635e935d9/storage/src/mozStorageService.cpp

Mostly just changes to strings, all very innocuous.  It's possible that another part of bug 633653 is the problem, but maybe this defect pre-dates bug 633653?
Supposedly the crash happened here:

nsCString
Connection::getFilename()
{
  nsCString leafname(":memory:");
  if (mDatabaseFile) {
    (void)mDatabaseFile->GetNativeLeafName(leafname);    // crash
  } 
  return leafname;
} 

and the faulting address was 0x0.  That seems surprising, givn the mDatabaseFile null-check immediately preceding.
Hey look, somebody else is seeing this!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 654573
(Assignee)

Updated

7 years ago
Crash Signature: [@ mozilla::storage::StorageMemoryReporter::GetPath]
You need to log in before you can comment on or make changes to this bug.