virgintrains.co.uk - Buying train tickets fails at the Mastercard Secure Code confirmation page if third party cookies are disabled

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 530752 [details]
Screenshot

Like many online retailers, Virgin Trains requests your credit card online PIN (in my case, my mastercard secure code) as the final step before processing your order. 

However, if third party cookies are disabled, this step fails, leaving you with an iframe showing the Virgin Trains account login page in the center of the page, rather than the order confirmation receipt (or an error message explaining what the problem is).

1) Disable 3rd party cookies in Firefox prefs.
2) Go to https://www.buytickets.virgintrains.co.uk/
3) Fill out journey details, to find a ticket to buy
4) Log in/create an account/enter credit card info when requested; hit "confirm order" on the payment page
5) At the mastercard secure code page, enter your secure code and press submit

Expected:
Ideally after a few seconds, the "your order has been successful, here is your receipt" page is shown. Failing that I would at least like a "you have third party cookies disabled, see <here> for how to enable" error message to be shown.

Actual:
No error message shown, but the iframe that previously contained the secure code entry form, now shows another page on the Virgin Trains website - with a login form. Logging in using that form does not make the order confirmation page appear. See attached screenshot.


Note:
I noticed that on the mastercard securecode entry form; the requesting website was "thetrainline.com" (another UK train ticket ordering company) rather than virgintrains.co.uk. I can only think they outsource their ticket sales - and using the 3rd parties e-commerce system doesn't work if third party cookies are disabled.
Ed, is this still an issue now that bug 664721 is fixed?
(Reporter)

Comment 2

7 years ago
I'll test this the next time I order a ticket (week or two).

Thanks for pointing out bug 664721 :-)
The real thanks go to tvk for pointing to this bug from that one.  :)
(Reporter)

Comment 4

7 years ago
Just ordered a ticket with third party cookies disabled using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110728 Firefox/8.0a1 and it works fine now. Looks like bug 664721 did the trick :-)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Depends on: 664721
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.